Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Today my cousing called me with a problem on his 2007 megacab six speed. It progressively has been dropping in RPM and wont stay running without revving it. This isn't the first time this has happened, it will blow white smoke a bit and now it is blowing black smoke. He has no mods on it although he did run an MP-8 for a short period of time. The problem just goes and comes and I think Chad mentioned this to Chris when they spoke. Has anyone had this happen or heard of this? :confused013:
 

·
I wanna go fast...
Joined
·
3,471 Posts
Not sure, sounds like a RP issue, maybe sticking injector. Gonna see if I can get this thread moved to 3rd gen powertrain for more exposure.
 

·
West Virginia Chapter VP
Joined
·
1,388 Posts
injector problem
That don't sound good. Can someone explain how to pinpoint for sure or where we need to start?

May be worth a trip to the stealership:S: and maybe they won't see that a MP-8 was on it. Injectors get pricey in a HURRY:doh: If he gets lucky warrenty will cover it:thumbsup:
 

·
Master of Mayhem NASFIG
Joined
·
8,806 Posts
have you checked the oil level, black means they are dumping to much fuel and white means its unburned fuel, could be the fca but i doubt it
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #7 ·
He took the truck to the local dealer today and had it everything gone over... The code came back up and they said the the code showed it was the fuel filter... This surprised me because he said he had checked it and changed it not long before. Thanks guys I dont know how long it will go without it coming back again but we will see
 
1 - 7 of 7 Posts
Top