Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
This has been happening for the past 9 months and im really wantin to fix it. after she gets warmed up it will go into this rough erratic, 900 rpm idle and when you let the clutch out in 2nd it will kill the pickup, 1st gear it just lugs down to around 600 rpm and itll take off , the thing seems sluggish a little when it happens, i can shut it off for a half hour, start her back up and its perfectly fine, im thinkin its the brain box on the vp, i dont know if any sensors would cause this, any help would be appriciated. its a 5 speed, 298000 miles, raptor with 16psi and 1/2 inch line to vp, i put a 9 micron before raptor and 4 micron after raptor, dosent drop but 2 psi at WOT, got a comp box on it and 5 in ex and cold air. It will do this rough idle almost always after i get off the interstate The vp thats on it has around 45000 on it, the idle is almost the same as Steveo 24's video,
Thanks Zach
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #4 ·
come on someones gotta have the same sorta problem, all the threads ive seen kinda like this all dont tell if a sensor, bad vp brain box, ecm, or its ground fixed the problem, any help guys?????
 

·
Registered
Joined
·
4,938 Posts
your telling me the psi drops to 2 at WOT?

outside of that if it is a rough idle it could be O rings on your inector lines, or your APPS is going out?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
it drops from about 17 to 15psi, the as far as the idle it ramps up to 950rpms and stumbles and spudders once its in high idle, the only way to get it to normal is to let the pu cool for 15 mins or so, it also wants to die when in high idle mode wen u let the clutch out in first gear and in 2nd it will kill it, the high erratic idle is intermitent, and only sometimes does it when its warmed up
 

·
Registered
Joined
·
175 Posts
when it starts cold dose it sound fine then when it warms up it has a skip
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
its fine when its cold it will skip/ studder and go to high idle when its warm i think its a bad vp computer according to bluechip diesel
 

·
Registered
Joined
·
175 Posts
oh no cuz mine dose the same thing. u didnt happin to find out what that cost
 

·
Registered
Joined
·
95 Posts
I know this is old post but anyone have this issue and figure out what it was?mine idles rough after it’s warmed up but idles fine when cold
 
1 - 10 of 10 Posts
Top