Dodge Cummins Diesel Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter · #1 ·
Installed lights, wired up. Drive truck! Zero issues. They work great!!

Thanks for taking the guess work out! Wished I had started with you guys first time around!
 

·
3 footin' through life
Joined
·
12,300 Posts
Did you use the kit to resolve issues with "lamp out" indications?" Did you use 55w or 35w?
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #4 ·
Just order the kit of retro solutions, it comes with everything you need.
 

·
3 footin' through life
Joined
·
12,300 Posts
Are you guys dropping them in the stock housings? I'm thinking to start with the fog kit in 3,000k. And then Headlights in 6000k.
 

·
Registered
Joined
·
45 Posts
I have them in stock housings, 3000's are pretty yellow and i wanted pure white so i went with 6000.
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #8 ·
I choose the 4300K, because it has the highest lumens output. Stock color for Benz, Audi, BMW.
 
  • Like
Reactions: Broaner

·
3 footin' through life
Joined
·
12,300 Posts
Thats some good info. I was originally planning to do the 3k fogs, 6k heads combo. Now I'm thinking all 4700.
 

·
Registered
Joined
·
3,259 Posts
Over year on mine working tits
 

·
Registered
Joined
·
2,352 Posts
over a year on mine as well! :thumbsup: 6k has a slight blue tint to it....'slight'.
 

·
Registered
Joined
·
181 Posts
A little over 2 yrs on my 8k in my heads and fog never an issue other than making people mad.....that's not what I'm out to do, I like to see well at night and this system is the ticket!
 

·
Registered
Joined
·
198 Posts
kits completely plug and play? bolt right into stock headlight houseing and clicks right into where oems were???
 

·
Registered
Joined
·
379 Posts
Junk. ......give them a month and see if they still work.....
Agreed, I went thru 4 ballasts and hours of troubleshooting and eventually tossed them in the trash. When they worked they were good, but they drove me nuts shutting down and finally just not working.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #17 ·

·
Registered
Joined
·
33 Posts
8k. Love em. Wouldn't trade em for anything.
 

·
Registered
Joined
·
847 Posts
<div style="margin:20px; margin-top:5px; ">
<div class="smallfont" style="margin-bottom:2px">Quote:</div>
<table cellpadding="6" cellspacing="0" border="0" width="100%">
<tr>
<td class="alt2" style="border:1px inset">

<div>
Originally Posted by <strong>jtaubrey</strong>
<a href="showthread.php?p=6494553#post6494553" rel="nofollow"><img class="inlineimg" src="http://image.autoforums.com/cumminsforum/buttons/viewpost.gif" border="0" alt="View Post" /></a>
</div>
<div style="font-style:italic">Agreed, I went thru 4 ballasts and hours of troubleshooting and eventually tossed them in the trash. When they worked they were good, but they drove me nuts shutting down and finally just not working. <br />
<br />
<font color="gray">Sent from <a href="http://www.autoguide.com/mobile" target="_blank">AutoGuide.com Free App</a></font></div>

</td>
</tr>
</table>
</div><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><br />
<br />
Bought hid for headlamps and fogs, within 6 months 1. Ballast almost caused a fire and one bulb is toast. And the best part this company has no phone number.. Retro solutions are junk
 

·
Registered
Joined
·
847 Posts
<div style="margin:20px; margin-top:5px; ">
<div class="smallfont" style="margin-bottom:2px">Quote:</div>
<table cellpadding="6" cellspacing="0" border="0" width="100%">
<tr>
<td class="alt2" style="border:1px inset">

<div>
Originally Posted by <strong>moose2514</strong>
<a href="showthread.php?p=6592089#post6592089" rel="nofollow"><img class="inlineimg" src="http://image.autoforums.com/cumminsforum/buttons/viewpost.gif" border="0" alt="View Post" /></a>
</div>
<div style="font-style:italic"><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><img src="http://www.cumminsforum.com/forum/images/smilies/agree.gif" border="0" alt="" title="Agree" class="inlineimg" /><br />
<br />
Bought hid for headlamps and fogs, within 6 months 1. Ballast almost caused a fire and one bulb is toast. And the best part this company has no phone number.. Retro solutions are junk</div>

</td>
</tr>
</table>
</div>May i ask how you wired them, did you ensure you had proper ground? did you use adequate dielectric grease on all connections that required it? Just trying to figure out why you think that retro solutions are junk personal experience?
 
1 - 20 of 22 Posts
Top