Cummins Diesel Forum banner

rebuilt ve now runaway from startup HELP!!

1511 Views 7 Replies 3 Participants Last post by  dozer12216
I had some serious fuel leaks coming from my ve pump. I purchased the rebuild kit and followed the ve pump rebuild forum as I found on the cummins forum. I fixed the fuel leaks and my shut off solenoid while in this process. and to throw this out there someone has gutted the top of the fuel pump no fuel pin no spring that goes around the fuel pin and no diaphram.

now when I crank my truck up it spits a couple times blugh blugh blugh then revs to the moon. luckily my shutoff solenoid worked and was able to kill it immediately. I have tried adjusting the throttle shaft where the marks are, no difference. tried loosening my three main bolts that hold the pump on thinking its maybe out of timing, no difference.

its pouring out black smoke while it does this as well, if tried adjusting the main fuel screw all the way in and all the way out, no difference.

I installed the 3800 gov spring when I put the rebuild kit in that's the only thing different I did to my pump.

my truck cranked up and purred everytime with no problems before just had the fuel leak, now I feel like im screwed and cannot find any information on how to fix the runaway or find ANYONE that's had the same problem that im having

so if anyones out there that has ANY advice on how to help me figure this out gosh you'd be a lot of help

ive thought about buying a new pump but whos to say that's going to fix it and be a waste of money when it could be something so simple if any help would be much appreciated thanks alot
1 - 8 of 8 Posts
Sounds like something is stuck on the inside of the pump giving that runaway situation. Have you tried pulling the pump top again and checking it out?
no I haven't yet, I def. will though any ideas on what to look for that might be stuck cause I have no idea really.

im going to take the top off and install the stock spring as well just to see

if any ideas on what to look for thanks
I don't think it'd be the gov spring doing it, but something to do with the mechanism possibly. Or something broke.

I will say it'll likely be very apparent once the top is off
I pulled the top off came up with the idea that maybe one of the levers on the top part was holding the throttle lever wide open. I also installed my stock spring back just till I can figure this out but no difference at all. I also tried killin the motor with the manual lever and it did nothing, it always worked before could this be a sign?
Is there a proper way of installing the top part that maybe I am holding the throttle shaft part wide open?
this is how I have my throttle shaft set up does anyone have any ideas on what I have done wrong reinstalling my ve pump?

it spits a couple times then revs out the frame from startup HELP!!!!!

Auto part Engine Automotive engine part Carburetor
See less See more
Take pump the shop that deals with this pump. You probablly have messed something up internally. Sorry
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.