Dodge Cummins Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1 (Edited)
start with a little hello to everyone. I recently put in a rail pressure gauge and was supprised to see that my rail pressure was considerably low. at around 70 mph or so no mods on, my rail pressure is only around 10k or so. i can have it wot and only get like 15 to 16k. If i turn on the edge to lvl 5 and floor it it will increase to around 18k to 20k and then all the sudden spike into the upper 20s and the check engine light comes. the codes say to high a voltage on fuel sensor. i believe it should be around the 15 to 16 range just cruzing at 70 or so if im correct. i got another set of nozzles here to see if these are leaking, just havent had time time to install yet. kinda wanted to see what some other folks thought. thanks aaron
 

·
Registered
Joined
·
67 Posts
Discussion Starter #2
no one knows anything bout this stuff?
 

·
Registered
Joined
·
2,415 Posts
this is me cruising at 70kph (45mph) i havn't been on the freeway since i got my rp guage so i dunno. its the bottom guage, its sitting at 10
 

·
Registered
Joined
·
3,578 Posts
How's your supply pressure looking?

Change your fuel filter.

The next step is to run the engine at idle and check for excessive return fuel flow.
 

·
Registered
Joined
·
999 Posts
Is your rail capped? It might be leaking now if it is not. You dont have to cap it you can just replace it but costs a lot more that way. What is your idle rail psi?
 
1 - 5 of 5 Posts
Top