Dodge Cummins Diesel Forum banner

Question about my Edge

812 Views 11 Replies 5 Participants Last post by  Threeleggedgoat
Does it have a boost fooler built in? It says im running 41psi what is a stock truck running?
1 - 12 of 12 Posts

· Premium Member
Joined
·
2,503 Posts
yeah the edge has a boost fooler built into it, i can hit 41psi as well but from what people say on here anything past 35psi with a stock turbo is just hot air.
 

· Premium Member
Joined
·
2,608 Posts
yeah the edge has a boost fooler built into it, i can hit 41psi as well but from what people say on here anything past 35psi with a stock turbo is just hot air.
Yeah 35 is the max "cool" air for a stocker. When I had my Edge I could hit a tad over 40psi also. It does have a boost fooler built in.
 

· Premium Member
Joined
·
2,608 Posts
is there a way to turn it off if wanted?
There is no option on mine. I ran it for over a year and you should have no problem at all. :thumbsup: I doubt you are hitting 40+psi many times a day anyway.
 

· Premium Member
Joined
·
2,503 Posts
but u can set max boost with the edge where itll defuel if u go past whatever psi u set it on.
 

· Registered
Joined
·
159 Posts
Do you run a mechanical boost guage or are you going off of the attitude monitor? I'm pretty sure that the attitude reads a little high generally. I have my boost defueling set for 42psi on the attitude monitor. I turned off the defueling point and saw 48psi before I lifted. I don't really think that I was truly boosting 48 though...
 

· Premium Member
Joined
·
2,608 Posts
Mine is spot on. It is through the map sensor. The only reason I know it is right is because I have the Edge hooked up for gauges and have a boost and EGT gauge. Edge runs exactly with them! Not sure why some people have problems with theirs but mine has always been perfect.
 

· Registered
Joined
·
159 Posts
I saw you were running a mech. gauge as well...that's part of why I posted. I hoped you'd chime in. I don't have a mechanical to compare so I really don't know if mine is off. I was just surprised at how high of a boost reading I was getting. I think I may try to get another gauge installed...
 

· Premium Member
Joined
·
2,608 Posts
I saw you were running a mech. gauge as well...that's part of why I posted. I hoped you'd chime in. I don't have a mechanical to compare so I really don't know if mine is off. I was just surprised at how high of a boost reading I was getting. I think I may try to get another gauge installed...
Yeah it seems like some people claim their edge is off and others don't have a single problem with it. :confused013: Like I said both EGT and boost are SPOT on exact. Even though the Edge is tied into the map sensor and my gauge is hooked into a "boost bolt" that reads straight from the intake. two different spots, two different methods, exact same reading.:thumbsup:
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top