Dodge Cummins Diesel Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
Works if I park it in the sun here in sunny SoCal (by the Mex border=hot) in summer but not in winter. If I crank the heat on defrost (it's mounted on the dash) it works, if I crank the AC on def it quits. I already replaced the probe per Autometer tech supp against my better judgement, no change. The gauge acts like it's sticking usually around 600. If I romp it and it's kinda warm, sometimes it'll pin and stick for a while, then back to 6. Who's got ideas?

Thanks
 

· Registered
Joined
·
9,910 Posts
where is the gauge pulling its power from?

I cant recall where i pulled my power from, but it will go funky for a second when i turn the heater/AC on!

Only thing i could figure is that its just 'dirty power'
 

· Dumbass
Joined
·
7,169 Posts
or if its an auto meter it is the gauge servo crapd out on you. if you want i can show you how mine is glued at 400 degrees. i had to buy a secondary pyro gauge. if you do a search, you will find a bunch of posts about this. not an epidemic, but enough that its not hard to find other guys. i talked to some guys that were on their 3 or 4th gauge already! :shock: what can ya do. mine started off slowly, i'd smack it around and it would loosen back up and work, and then it finally just stuck. hopefully you can just put a blanket on yours and be ok, but it oculd be on its way out. . good luck man.
 

· Registered
Joined
·
124 Posts
Discussion Starter · #5 ·
Checked grounds. Mine is definitely temp related. It's not a quick bleep when I turn AC on/off. When I warm it up, it starts working, when I cool it off, it quits.
 

· Registered
Joined
·
124 Posts
Discussion Starter · #6 ·
Talked to AutoMeter, they said to send it in, think I should or just get another gauge?
 

· Registered
Joined
·
9,910 Posts
That depends, personally i would just say F'k the hassle and just buy another one.

But then again my geographic location plays a big role in that situation (im not going to wait over a month for a stupid gauge to get fixed!)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top