Dodge Cummins Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I recently had to take my p7100 injection pump off to replace my leaky pushrod cover gasket. While i had the pump off i slid the fuel plate foreward and turned the smoke screw 1 turn in. Got everything back together and primed, started. Now it seems like it has no power...What should i look for?
 

·
Registered
Joined
·
67 Posts
I would check for air leaks, intake manifold gasket, etc. and check your fuel lines to and from tank for leaks.. Do you have Gauges yet? Need to tap P7100 inlet for FP gauge and let us know what it's running. Could also be something in p7100 And timing could have fell back to stock from being advanced (top end power would be decreased) more than likely. Do you know exactly what originals owner or previous have done to it? Because stock form 95 are turds with 160hp pump.

Oh one more thing came to mind.. Sometimes sliding fuel plate full forward causes governor arm to fall below plate and it will have minimal fueling all rpm. It may need adjusted. Basically u take cover to plate off, bump throttle linkage to full throttle and see if it hits very bottom of plate. I guess 2/3 or more often than not the arm falls below the plate. That could very well be your culprit. Do a thread search for governor arm falling below fuel plate for pics
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top