Dodge Cummins Diesel Forum banner

Pump ticking noise!!

15399 Views 8 Replies 5 Participants Last post by  Cummins FTW
Hey guys I just bought a 12v as my second rig. When I first start it up I dont hear anything just a healthy running motor, after I drive it around and get it warmed up I hear a loud ticking noise coming from the injection pump?? anyone ever get anything like this...? truck is stock besides str8 piped... Any help would be awesome guys
thanks
1 - 9 of 9 Posts

· Registered
Joined
·
698 Posts
Discussion Starter · #2 ·
BUMPPPP come on guys anyone ever get this ticking noise before mods to there pump... Im wondering when I turn stuff up itll change it??
 

· THE Hood Stack Guy!
Joined
·
3,068 Posts
Sounds like you got an air bubble in the fuel system. If its real loud, you got a good amount of air. Most of the time ticking can mean 2 things, high timing and a bit of air in the injection lines.
 

· Registered
Joined
·
9,910 Posts
The lift pumps are famous for ticking when their springs get worn out or break. A worn out overflow valve can cause some ticking also...
 

· Registered
Joined
·
698 Posts
Discussion Starter · #5 ·
The lift pumps are famous for ticking when their springs get worn out or break. A worn out overflow valve can cause some ticking also...
Not so sure its the lift pump only cuz of the noise being loud right by the pump... Ill try changing the overflow valve... The ticking speeds up the the RPM's and goes the the speed of the engine.... still think the valve could do that?
 

· Premium Member
Joined
·
12,495 Posts

· Registered
Joined
·
17 Posts
Check your fuel pressure at your injector pump. Mine was ticking/knocking after the truck got warm. Everyone I talked to said it was NOT THE INJECTOR PUMP going out. Well now that I have a new injector pump, they do go out.

When mine would start knocking/ticking I would stop the truck and pour ice water on the pump. Then wait a minute and start the truck - no ticking/knocking.
 

· Registered
Joined
·
698 Posts
Discussion Starter · #9 ·
Alright so new update.. Today I replaced fuel filter and pre filter just main stuff... and did all the free mods to the pump... Truck of course didnt wanna start for anything so I cracked a pump line and she fired up... havent driven her around a ton but I didnt hear any ticking noise... will report back tomorrow guyss thankss
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top