Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Long story short....

I have a Prodigy controller hooked into the factory harness and it has not worked since day one. The controller works fine but it keeps telling me there is a short in the system and will not work the electric brakes on my 24' v-nose. All lights work fine.

I took out the controller with my wiring harness and put it in my friends factory harness in his 6.7 and its works perfectly hooked to my trailer.

Have taken the truck to the dealer twice and they cant fix it and dont know whats wrong with it.

So I am at my witts end trying to figure it out, I am not sure what I can do to fix it since I dont think the dealer is going to do anything different and I am tired of driving 40 min out there to get no answers.

Anyone have any information on what I should be reading for volts/ohms at each terminal on the receiver (where you plug the trailer in). My roommates truck(Chevy) reads different values on the trailer brake(volts) and ground(ohms) then mine so I am wondering if I could have an issue with the actual receiver adaptor.

Any help/ideas/readings from your receiver adaptor would be appreciated.
 

·
Registered
Joined
·
77 Posts
just had my new brake controller installed, the new tekonsha that is newer than the prodigy and for $30 the outfit ordered a whole new wiring harness that would hook into this new brake controller without having to splice wires or use any connectors mid stream at all. Had the shop so it where I bought my 5th wheel.
 

·
Registered
Joined
·
1,689 Posts
go to a Tekonsha dealer and have them hook into a new Prodigy and see if the code returns. I had one that did the same thing and it was replaced under warranty after I had it for 2 years. My guess is it showed the 09 code right??

Chris
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
go to a Tekonsha dealer and have them hook into a new Prodigy and see if the code returns. I had one that did the same thing and it was replaced under warranty after I had it for 2 years. My guess is it showed the 09 code right??

Chris
i dont know about any codes? it doesnt come up on the lcd about any code just keeps blinking S.H. What doesnt make sense is why it doesnt work in my truck but does in my friends truck which is the same exact truck...
 

·
Registered
Joined
·
1,689 Posts
If it works in your buddies and you are using the same wireing harness then it stands to reason you may have a short in the wiring of the truck. Tell the dealer you want to have a trailer shop look at it on there dime. They have the knowledge to find this kind of thing.

Also, take the controler and exchange it just to rule it out. Tekonsha is very good about these things. The code was talking about is an 09 code mine would throw on the Prodigy itself. It would come and go.

Keep after the dealer!! If you can't tow your trailer then what is the point of a diesel pickup:(

Chris
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
I guess i will go with the obvious. Check the fuses, maybe you have one out.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
thanks for the responses guys. i have already checked the fuses and nothing came up. i figured it would be a wiring problem within the truck but I just wanted to see if anyone had any other ideas...

thanks for the help
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
just called the dealer and the "manager" told me that his service guy wrote something about the controller being wired wrong. I am following the instructions on teknosha's website but just to be safe, mine is wired like so:


OEM Harness ---- Prodigy
white w/red ---- black
blue ---- blue
gren w/black ---- white
blue w/white ---- red


Hows does that look to everyone, is that how everyone with a 6.7 has their prodigy wired into the factory harness? thanks
 
1 - 8 of 8 Posts
Top