Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1 (Edited)
Problems after turbo install update with codes

Drove the truck today with the extreme tune and still made 36psi. So I decided to check the codes 0234 0602 showed up but the CEL never came on.


I just put on a HTT 62/12 on a 05 predator/puck stack, exhaust, intake. Problem is the turbo spools quick as snot on ice but it never starts to pull hard. Boost hits 36 and just shakes between 34-36. Feels like its fixin to lite around 20psi starts to pull real hard for a split second then just quits. It feels almost like the truck is defueling. Plenty of smoke down low then the turbo cleans it up on the topend egt's are running about 1350-1400 on a pull from 45-90 so I would think with those egt's it wouldn't be cutting fuel would it??

Also while doing the turbo install the batteries went dead on me.

And one other thing about 10000 miles ago the truck turned into a TOTAL turd and I had everything checked and it was all good. F/P, map, FCA, oh and i put new injectors in it to at that time. and nothing took care of the power problem. So i stuck the diablo on and it solved it for some reason ran just like it did with the BDPP.

Need some idea's here.
 

·
Registered
Joined
·
202 Posts
sounds like you need a boost fooler. I see 42-45 psi on a stock turbo with my quad box. It has a built in boost fooler.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
boost fooler came with the turbo. The only setting ive tried is the 100hp setting on the predator with out the pressure box on. Just feels like a turd. I know it isnt the turbo because it spools GREAT.
 

·
Registered
Joined
·
202 Posts
whats your fuel pressure to the CP3 and whats your rail pressure at?

could be your draining the rail?

what does a turd feel like exactly?
 

·
818
Joined
·
2,248 Posts
Sounds like you need to tune the wastegate. You could use some more boost, say around 40 to 45psi. Turn up the boost and watch it pull hard. Also, you may want to invest in some more electronics like a Smarty or Predator programmer.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
I dont have a rail gauge and dont recall what the f/p was off the top on my head.
I dont think Ive got enough fueling to drain the rail. And by a turd I mean slow as sh*t. But I would guess the feeling would depend on if it was fresh or not.

And smoker i have the predator/puck stack I just messed up in the 1st post. I'm going to pick my smarty up the end of the week. But the truck doesn't feel as strong as it did with the stock turbo.

I've had a BD/Mp8 stack, tst, and now just a predator/puck and the truck is freakin slow right now its a problem I just dont know what it is. And dont really know where to start.

And I am going to wait till i get the smarty to mess with the gate.

Like i said as soon as it feels like it wants to pull it just planes out like it is defeuling. I also think my egt's are a little high.

Anyone think its possible to have weak batteries and it cause these kind of problems??
 

·
Registered
Joined
·
255 Posts
Did you install the plug for the electronic wastegate? If you did that is not a boost fooler. That just eliminates codes from the servo being unplugged.
 

·
Registered
Joined
·
106 Posts
Im in the same boat with you. I mean to the t. I have a BDTD thought stack with a Mp8. Im geting a smarty in ky this weekend. Let me know how you fix it. On crazy lary my fuel pressure with down to 2/3psi at wot.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
Yes I just installed the plug that came with the turbo.

I will keep you posted on how I get it fixed. One of my friends was running the same fueling as you with a SB66 and it done GREAT but he had 100hp sticks. I'm gonna try to get my smarty picked up today if not it will be Saturday when i return from Miami. From what I hear that will fix it right up.

Would I still need a actual boost fooler with the smarty or no???
 

·
Registered
Joined
·
451 Posts
i also just have the power puck with intake. i put it on the 90 horse setting and i think i can tell a difference, it pulls alittle harder but doesn't seem to make that big a difference. without spooling it up it won't slip the tires or smoke. should it with the 90 horse? i know i should just check the gauges but those come in next week.
 
1 - 10 of 10 Posts
Top