Dodge Cummins Diesel Forum banner

Problem with Compounds or lack of power?

239 17
New here guys,been reading your posts for years, and owned many dodges. Best truck ever made . Dont know if this is the right spot but..here we go. I have my 12v did the compounds on her. Runs great but will not spool over 20lbs. Checked almost everything possible I could read up on. And this is why I'm here. Let me know what you need to know I'll answer. Thanks
1 - 18 of 18 Posts

·
World Champs!!!
Joined
·
28,234 Posts
…owned many dodges. Best truck ever made .
Here here buddy! An internet toast to ya🍻

What’s your fueling? I see stock injectors but what about the fuel plate? If you’re not driving them hard it’s not producing much boost. Granted I would expect more than 20 but certainly fuel is a key to making the setup happy.

My initial reaction is you’re not throwing enough fuel
 

·
Registered
Joined
·
255 Posts
Best truck? Lol, maybe best truck engine...

Advancing timing might help.

Do you have 3k or 4k governor springs? Didn't see them mentioned in your signature. Those could help.

More fuel too, as said above.
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #4 ·
As is my thought not enough fuel, fuel plate dosnt exist its on my tool box, my next step of diagnosis is removing asc totally and see if it runs better to eliminate if i have it set up wrong, I have the comp 973 valve spring in my LP. Fuel at idle is around 48 to 50. At wot never drops under 30lbs. Pyro sits at 700 or so. I have 4k gsk kit too . Need to update sig again. Done it around 5 times already. If I power brake truck, almost instantly it spools up and breaks all 4 tires loose within a few seconds. Just not over 20lbs. I have spring gate on 351. Whistles like crazy but I don't think it's even popping to the 45 turbo yet.
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #5 ·
Best truck? Lol, maybe best truck engine...

Advancing timing might help.

Do you have 3k or 4k governor springs? Didn't see them mentioned in your signature. Those could help.

More fuel too, as said above.
I've owned em all,I always come back to my dodges lol.
 
  • Like
Reactions: jason867

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #8 ·
It's allready irritated me for the day. So I came home . But I will pull the afc tomorrow and see what happens. And I put a new shut off solenoid on and it is set correct .
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #9 ·
Once I figure out the problem I will up timing and I have bigger sticks for it. I just wanted to fix the problem before I started adding stuff. It ran good and strong stock .
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #10 ·
Automotive tire Hood Automotive exhaust Automotive fuel system Motor vehicle
Automotive tire Hood Motor vehicle Automotive lighting Automotive exhaust
Gas Auto part Machine Nut Metal
 
  • Like
Reactions: 56Cummins

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #11 ·
Just incase you guys were interested in my set up
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #12 ·
Update..took afc off rechecked my work . At 30 psi shop air I'm at full travel . Took it apart looked at diaphragm everything looked good. So I removed foot went for ride same situation. 700 to 800 egt. Nothing over 20 to 22lb boost. Timing is stock 12.3 on 160 pump. I'm lost I'm not getting anywhere. Bad bypass? Is the fuel running strait threw pump? Need a good 12v mechanic near me lol.
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #14 ·
I tried that yesterday.and also doubled checked the height . No change. Today I pin timed pump and motor. Timing is dead on as well. The thing is beating me up. I've been wrenching since I was 10,millwright by trade. And besides the turbo buick forum and this one,I have no social media at all . So I'm saying I'm stuck desperate lmfao. I don't give up easily but dam everything on paper is dead on. There is something I have to be missing. If my injector seals are leaking wouldn't I loose compression? And if they are would I have disel around them? I'm reaching here for any answer. Not making any sense to me. I can't compare from then till now cuase I parked her for 5 or 6 years and never turned anything up or played with it. All taper screws were still intact till a month ago when I started to build it.
 

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #15 ·
Thread closer...did some research last night. The efficiency of my 351 over the hx35 is way superior. Ok. Then stumbled upon flow rates of 1994 to 1995 stock injectors. They don't flow any where near enough to push my 351 by itself let alone compounds.
Woke up this morning put my 5x16s in and I can't keep the truck strait. Runs like a pack of gorilla's now. Thanks . Back to my cave now.
 

·
Registered
Joined
·
17,739 Posts
I sugget you bump up the timing so all the fuel gets burned.
 
  • Like
Reactions: jason867

·
Registered
2016 megacab ,1995 12v
Joined
·
11 Posts
Discussion Starter · #17 ·
Did that this morning as well,Set it at 16.5.
 
1 - 18 of 18 Posts
Top