Dodge Cummins Diesel Forum banner

Power Steering/Hydroboost whine and feedback

31043 Views 28 Replies 17 Participants Last post by  Bl66
I was asked to take a look at a friends '14 who is having issues. One of the things is that there is a whine sound that gets loud at 1000-1100 RPMs with increased sound and feedback coming through the steering when turning or using brakes. So I believe that it has something to do with the hydroboost system or power steering?

The fluid is topped off and he flushed the system and refilled with with Amsoil Synthetic fluid. I wasn't sure if there was an inline filter somewhere in the system that may need cleaned out or other easy places to look before really tearing into it. Thanks
1 - 20 of 29 Posts

· Registered
Joined
·
1,711 Posts
If it is more of a hiss than a whine, maybe the problem in the video below? It doesn't sound like what you described but I thought it might be worth a shot

 
  • Like
Reactions: Zaicran and KBoom

· Registered
Joined
·
519 Posts
Discussion Starter · #3 ·
Badunit, thanks for the response but this is a different sound. From my research the 14s do not have that style pressure line with the restriction as shown in the video.

The sound I'm hearing is hard to explain. It almost sounds like when the fan is engaged at lower speeds. Like a "whoosh"
 

· Registered
Joined
·
50 Posts
I was asked to take a look at a friends '14 who is having issues. One of the things is that there is a whine sound that gets loud at 1000-1100 RPMs with increased sound and feedback coming through the steering when turning or using brakes. So I believe that it has something to do with the hydroboost system or power steering?

The fluid is topped off and he flushed the system and refilled with with Amsoil Synthetic fluid. I wasn't sure if there was an inline filter somewhere in the system that may need cleaned out or other easy places to look before really tearing into it. Thanks
Father in law's 2013 does the same thing. Curious to see what you find.
 

· Registered
Joined
·
519 Posts
Discussion Starter · #7 ·
Is the fluid in the reservoir becoming aerated or foamy when the issue occurs?
No. I have had the cap off checking it and the fluid looks normal. No foam or aerating that I can see
 

· Registered
Joined
·
519 Posts
Discussion Starter · #8 ·
Are you sure the truck isn’t installed with the “90’s Ford power steering package?” Sorry I know this doesn’t help, it’s just the first thing I thought of when reading the post title! Good luck in getting this fixed.

Chris
Haha, I actually laughed out loud when I read this! I get a chuckle every time I'm looking around for something with a blower to come down the road but it's just an old Ford
 

· Registered
Joined
·
519 Posts
Discussion Starter · #9 ·
Anyone have any insight??

The noise that it makes is the same as when you turn the wheels all the way to a lock and hold it there, like it's bypassing. Is there a filter that I can check somewhere in the system?
 

· Registered
Joined
·
211 Posts
Anyone have any insight??

The noise that it makes is the same as when you turn the wheels all the way to a lock and hold it there, like it's bypassing. Is there a filter that I can check somewhere in the system?
Did you ever find the noise? I’m currently chasing the same sound on my pickup.
 

· Registered
Joined
·
1 Posts
Is the fluid in the reservoir becoming aerated or foamy when the issue occurs?
Good morning. I’m having the same problem. Before I started the truck, p/s was full, brake fluid was full. As soon as I started it, I had no power steering and the awful humming noise. Popped hood and p/s fluid was empty instantly. I topped off, got steering back, humming noise still there. But p/s fluid is real foamy. Any information would be greatly appreciated. Thanks. 2015 6.7L
 

· Registered
Joined
·
1 Posts
I was asked to take a look at a friends '14 who is having issues. One of the things is that there is a whine sound that gets loud at 1000-1100 RPMs with increased sound and feedback coming through the steering when turning or using brakes. So I believe that it has something to do with the hydroboost system or power steering?

The fluid is topped off and he flushed the system and refilled with with Amsoil Synthetic fluid. I wasn't sure if there was an inline filter somewhere in the system that may need cleaned out or other easy places to look before really tearing into it. Thanks
i have a 2014 2500 bone stock with that same noise. did you ever find out what the problem was? and possibly the cost of the repair? thanks in advance.
 

· Registered
Joined
·
1,447 Posts
My 2013 has been making noise at the hydroboost for a few months - it sounds a lot like "alternator whine" coming through aftermarket stereos back in the 90s.

Then it started getting feedback through the brake pedal and steering wheel, particularly when I start the truck and immediately try to move the steering wheel. It's sort of a rough groaning feel.

Now my power steering pump is getting loud. It honestly does sound like an old Ford. I flushed the steering system this weekend and it changed nothing. If it gets worse I guess replacing the pump is the next step...
 

· Registered
Joined
·
3 Posts
I am having the same noise all of a sudden. Tried changing out fluid in power steering reservoir but it’s no different. I would like to know what you find out. Thanks.
2017 Ram 2500 I’ve been having the same noise for three months now. I took it to a dealership and the master mechanic said that it was normal. Today my power stringing pump went. I will update when I replace the pump the see if the noise goes away.
 

· Registered
Joined
·
1,447 Posts
@bcflyfisher @Josh83 you guys ever get this figured out? My 14 started doing it and I can only hear it in the cab. Cannot figure it out for the life of me and am worried about something crapping out while on a trip somewhere.
I haven't done anything beyond the fluid flush yet. Given that my first symptom was a whining hiss that sounded like it was right at the firewall I think the hydroboost needs replacing. That noise seems to change with steering/braking input and I also feel feedback through both.

My second (several months later) symptom, which sounds like gear noise, is probably the pump. It sounds like an old Ford PS pump or almost like a supercharger. I can rev it in neutral and the sounds changes with my rpm. I'll swap the pump in a couple of months before I start going on trips.
 
1 - 20 of 29 Posts
Top