Dodge Cummins Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter #1
Buddy's got a 97 12v with a 215pump. Mods are 4k gov springs, (plenty of fuel pressure), and an s300. Truck runs awesome under load, but it will pop and blow white smoke arpimd 2k rpms when free revving. He has adjusted/checked/double checked timing and has now put it back to 13.5* with no difference. Under load there is no problems and the truck has plenty of power........just trying to get this issue resolved :thumbsup:
 

·
Registered
Joined
·
77 Posts
I hate to say it, but this sounds like the classic symptom of slipped/too retarded timing. What method did he use to set his timing?
 

·
Registered
Joined
·
1,152 Posts
My truck did this...it was because like when we did injectors and fuel lines and such there was still alotta air in the lines even though we bled the outta them. SO I'm thinking air?
 

·
Registered
Joined
·
370 Posts
Hey man i had the same problem at in wyoming when i was at school cause of the cold and lack of air. Its definitly your timing advance it the best you can, i didnt have a gauge so when the crank was at tdc i put the pump where the timing pin was at the bottom of the hole. Idk how many degrees but trust me its just the diesel burning incompletly advance it and your white smoke and popping will be replaced woth black and smooth rev
 

·
Registered
Joined
·
229 Posts
double post
 

·
Registered
Joined
·
229 Posts
ok guys this is my truck, i first started with 21.5* and it would pop at 2500rpm then i set the timing at 17* same thing popping and white smoke but at 2200rpm so then i pin timed it for the stock 13.5* and same thing again but at 2000rpm thought it was the gov springs so i pulled them out and made sure the coils are off set from one another and it still pops and smokes.

thanks for the help guys
 

·
Registered
Joined
·
315 Posts
Mine does the same thing after the 4KGSK install. But if you let it warm all the way up, it lessens it alot. I think it has to do with stock timing, and how fast the truck revs up now, almost unatural for a diesel. But as stated, with a load on the engine, it doesn't skip a beat... moral of the story, the cummins likes to be loaded when romping on it.
 

·
Registered
Joined
·
77 Posts
I installed the 4k governor springs in my truck and did not have any of those symptoms. Are you sure you have the springs cranked down enough? I remember I really had to crank down hard on the new springs because they have a lot more tension than the stock springs. I even had to grind a special fork tool so that I could get enough torque to turn the nuts. Are you sure the posts in the center of the springs are the same height above the retainers as the stock springs?
 

·
Registered
Joined
·
229 Posts
Well guys I messed with the gov springs last night and it did nothing. And it will do the popping if it is hot, cold or anywhere in between
 

·
Registered
Joined
·
16 Posts
mine does this but it's more of a sputtering. air in the fuel lines is what i've been told but i can't find a leak anywhere. i don't have pump mods so that might just be coincidence
 

·
Registered
Joined
·
13,900 Posts
13.5* is "low" timing... if you're only turning 2600rpm, it's borderline. Bump it up to 17-18*, and it'll feel like a new truck.

air in the lines will usually kill the truck... if it does this repeatedly and runs fine under boost/load, it's timing related. guaranteed
 

·
Registered
Joined
·
84 Posts
my truck has done the same thing and hasnt done it since i got an air dog. so i thought mine was a fuel pressure deal. cause i bleed out my lines with the stock pump for a while and it never fixed the problem. but after installing air dog hasnt done it since
 

·
Registered
Joined
·
186 Posts
Definitely a timing issue mine did the same thing...bump it up to about 16-18 and u should be free of white smoke. Also if your aneroid spring is out put it back in and crank that star wheel up a couple of notches
 

·
Registered
Joined
·
1 Posts
Having the same/similar issue, did you ever get it resolved? Hazing at idle, white smoke, popping on free rev and on Excell, lack of power... But while pulling a trailer it is almost non existent. I've checked all the possibilities on this thread and it still doesn't run right, please help have been battling this for weeks with no improvements any input would be greatly appreciated!????

Mods: 1997 marine long block rebuilt 30k miles ago, deep dish pistons, arp head studs, 4k governer springs, 215 pump (timing @15°), 64mm phat shaft turbo (small amount of oil residue in piping), star wheel, fuel plate, and smoke screw have been slightly tampered with by the previous owner.

Located in northern Wisconsin, -5° this morning. Thanks for any input ???
 

·
Premium Member
Joined
·
4,707 Posts
All my trucks do that if you try free reving it before it warms up.
 
1 - 15 of 15 Posts
Top