Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 17 of 17 Posts

·
Premium Member
Joined
·
355 Posts
Discussion Starter · #1 ·
I got the new PMT download from Bully Dog in a zip file. I'm wondering if I replace all of the existing files on the SD card with those in the zip file.
 

·
Registered
Joined
·
36 Posts
Sorry turbodiesel5 I'm not sure about that one.. I'm picking up my PMT today so If I find anything out I'll give you a shout. good luck
 

·
HI
Joined
·
3,448 Posts
it will replace all the existing files
 

·
Registered
Joined
·
209 Posts
you have to clear the sd card and up load the 6.7 files so that there are 18 files (i think) on the sd card.
 

·
Premium Member
Joined
·
2,623 Posts
1. Erase all files off of the PMT Card.
2. Save and extract the attached folder.
3. Copy all the files in the extracted folder onto the PMT Card.
4. Take SD card to the PMT and select Menu/ Change vehicle.
5. Select 2006-2007 5.9L and wait for reboot.
6. Select Menu/ Change vehicle again.
7. Select 2007.5 6.7L and wait for reboot.
8. Now ready to install.
9. Read takes 20 mins. And Program takes another 10 mins.
10. 30 mins. total program time.
 

·
Premium Member
Joined
·
355 Posts
Discussion Starter · #8 ·
Very soon :peelout. after I take it for a spin im doing the egr delete and yesterday I had the H&S 5" turbo back installed.
 

·
Smells like Bananas
Joined
·
7,240 Posts
1. Erase all files off of the PMT Card.
2. Save and extract the attached folder.
3. Copy all the files in the extracted folder onto the PMT Card.
4. Take SD card to the PMT and select Menu/ Change vehicle.
5. Select 2006-2007 5.9L and wait for reboot.
6. Select Menu/ Change vehicle again.
7. Select 2007.5 6.7L and wait for reboot.
8. Now ready to install.
9. Read takes 20 mins. And Program takes another 10 mins.
10. 30 mins. total program time.
Kevin,

He needs to format the SD card. I found this out for myself also.

When you insert your card into the USB port and you open "mycomputer" to see the drive. Right click on it and choose format. make sure you have it on FAT and not FAT32. you will see that option in the box once you click on the Format option when you right click the SD Drive. Also dont do a quick format
 

·
Premium Member
Joined
·
355 Posts
Discussion Starter · #10 ·
1 more question, can't figure out why the egt's are reading so high, 1150 @ an idle? I have tried switching from pyro 1 to pyro 2 and also changing from factory pyro? does it have something to do with the 5" H&S ?
 

·
Smells like Bananas
Joined
·
7,240 Posts
no that is wrong. i have the BADP 5" with a Autometer Pyro. you should be around 500 to 600 at idle. At cruising on the highway you should be around 900 to 1000.
 

·
Premium Member
Joined
·
355 Posts
Discussion Starter · #12 ·
even before i start the truck it reads 1150?( with key in run position) I will call bullydog 2morrow.
 

·
Premium Member
Joined
·
5,814 Posts
1. Erase all files off of the PMT Card.
2. Save and extract the attached folder.
3. Copy all the files in the extracted folder onto the PMT Card.
4. Take SD card to the PMT and select Menu/ Change vehicle.
5. Select 2006-2007 5.9L and wait for reboot.
6. Select Menu/ Change vehicle again.
7. Select 2007.5 6.7L and wait for reboot.
8. Now ready to install.
9. Read takes 20 mins. And Program takes another 10 mins.
10. 30 mins. total program time.
Nice write up, I can do it but would have an issue putting it down like you did. Good Work, sticky that in your forum:thumbsup
 

·
Premium Member
Joined
·
2,623 Posts
Kevin,

He needs to format the SD card. I found this out for myself also.

When you insert your card into the USB port and you open "mycomputer" to see the drive. Right click on it and choose format. make sure you have it on FAT and not FAT32. you will see that option in the box once you click on the Format option when you right click the SD Drive. Also dont do a quick format
Yep I forgot to mention that some people might need to format the card:hateit:
 

·
Registered
Joined
·
2,882 Posts
1 more question, can't figure out why the egt's are reading so high, 1150 @ an idle? I have tried switching from pyro 1 to pyro 2 and also changing from factory pyro? does it have something to do with the 5" H&S ?
I bet that your kit has a fooler box to trick the ecm into believeing that the exhast is hotter than it really is. This is normal for the kit to work properly. You will have to install a seperate egt sensor to give you accurate readings.
 
1 - 17 of 17 Posts
Top