Dodge Cummins Diesel Forum banner
1 - 20 of 37 Posts

· Registered
Joined
·
202 Posts
Discussion Starter · #1 ·
I need help guys. I love the wealth of info on here and I have done some research but I could really use your help. I do not know what my truck is really doing. Thank you if you take the time to read it.
 

· Premium Member
Joined
·
12,665 Posts
could be a bad turbo if it's at speed, if at idle, could be the VP...:confused013:

go out and do the key trick for codes:

turn it on, off, on, off, on, DON'T crank, codes will read out on odo, write em down and post em here...:thumbsup:
 

· Registered
Joined
·
202 Posts
Discussion Starter · #6 ·
when I really need the power like passing somebody or pulling a grade with or with out trailer. When the power comes on it bucks. I can pull 45lbs of boost with zero surging when the adr. is off it only surges when I am asking for more fuel. If I bump the mins up on the pulse it just delays the effect put them way down and the problem is there even quicker. With the mins way down I don't have to really be into the throttle just giving it some go to accelerate is all it takes.
 

· Registered
Joined
·
202 Posts
Discussion Starter · #10 ·
My wastegate is completely closed off I have the rod as short as can be. And this problem was nonexistent four the first 4months of having these twins. Use to be smooth as glass if I wasn't running the beta tunes. I didn't even have the pulse then and I was more than happy. Although I hadn't towed with the twins yet. The first time I realized I had surging and a fluttering boost guage was on the first towing trip. Wich over the course of 400 miles I never took it over 40lbs. And no spikes either.
 

· Registered
Joined
·
202 Posts
Discussion Starter · #11 ·
I have sent the box in it checked out ok and I even tried a friends adr. and it did the same thing.
 

· Registered
Joined
·
465 Posts
P0253 Fuel Inj Pump Fuel Valve Open Circ

P0234 Turbo Boost Limit Exceeded
Had same 2 codes and truck surged bad. Turned out to be my alternator. Bad diode was leaking AC current into the system causing a surge. Was told to check out my alternator by Mark at TST and Chip at Blue Chip. Disconnect main lead off back of alt and run truck, if no surge its the alt. Make sure you tape up wire so it doesn't short on anything.
 

· Registered
Joined
·
2,237 Posts
Have you cleaned the battery terminals lately? Sounds goofy, but it's worked for lots of us, including myself. Something about something in the trans needs a strong enough signal or it will surge.
 

· Registered
Joined
·
202 Posts
Discussion Starter · #17 ·
Tapped it by soldering it on. I am going to have to try the alternator thing. Will post back if I get a chance today.
 

· Registered
Joined
·
202 Posts
Discussion Starter · #20 ·
Tried the alternator thing and still does it I have it on a 1000 tune right now just to try and keep it simple.
 
1 - 20 of 37 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top