Dodge Cummins Diesel Forum banner

please look and help!

678 4
I have having two seperate problems with my 03 ctd. My check engine light is on and it says low voltage map sensor. would the map just need replaced or is there something else to it?

Second problem, my abs and park break light come on together and I can sometimes hear and feel my abs pulsing. Is this also a sensor?

Please give me any info you can.
thanks
1 - 5 of 5 Posts

· Registered
Joined
·
755 Posts
with the brake light and abs sensor coming on, it might be the speed sensor. when you drive.. does the speedometer not work till 25mph? if so, then its your speed sensor. i replaced mine in march, i believe it was 40 bucks and it goes on your rear axle.
 

· Premium Member
Joined
·
19,751 Posts
Shibbyutman on here is pretty good with the abs stuff. You may want to shoot him a pm.



 

· Registered
Joined
·
431 Posts
Could it be time for new brake pads? I know mine on my 05 were OK but are getting low though I have not had a problem with lights or feeling abs. I pulled a couple of FULL truck loads in the back bed of crushed slate for my driveway and though everything worked ok and I took it easy. My brakes feel more spongy now upon being empty again then before and I also have felt my ABS pulsing once or twice. They have about 45,000 miles on them so I can't complain.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top