Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have having two seperate problems with my 03 ctd. My check engine light is on and it says low voltage map sensor. would the map just need replaced or is there something else to it?

Second problem, my abs and park break light come on together and I can sometimes hear and feel my abs pulsing. Is this also a sensor?

Please give me any info you can.
thanks
 

·
Registered
Joined
·
735 Posts
with the brake light and abs sensor coming on, it might be the speed sensor. when you drive.. does the speedometer not work till 25mph? if so, then its your speed sensor. i replaced mine in march, i believe it was 40 bucks and it goes on your rear axle.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
with the brake light and abs sensor coming on, it might be the speed sensor. when you drive.. does the speedometer not work till 25mph? if so, then its your speed sensor. i replaced mine in march, i believe it was 40 bucks and it goes on your rear axle.
no my speedo works below 25mph. any other thoughts?
 

·
Premium Member
Joined
·
25,250 Posts
Shibbyutman on here is pretty good with the abs stuff. You may want to shoot him a pm.



Dodge | Commins | Forum
 

·
Registered
Joined
·
443 Posts
Could it be time for new brake pads? I know mine on my 05 were OK but are getting low though I have not had a problem with lights or feeling abs. I pulled a couple of FULL truck loads in the back bed of crushed slate for my driveway and though everything worked ok and I took it easy. My brakes feel more spongy now upon being empty again then before and I also have felt my ABS pulsing once or twice. They have about 45,000 miles on them so I can't complain.
 
1 - 5 of 5 Posts
Top