Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 · (Edited)
hello, i have a 01 24 valve 4by4 all wheel abs, few days ago my abs and park brake light came on, then the brake pedal would kinda skip until it was too the floor, i tried to bleed the brakes last night but in the front the fluid came out in a trickle, all three abs sensors are reading, does anyone have a idea what could be wrong? is it the master cylinder? :confused013: thanks also it occasionally throws the p0500 and p1693 codes but they never stay on, they disapear after a few starts.
 

·
Registered
Joined
·
47 Posts
taking a shot in the dark, but my truck did the same thing on the 5 hour journey home with it, ended up being a rotted fuel line ontop of the fuel tank.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #3 ·
thanks, ill puller back in the shop n crawl under agauin
 

·
Premium Member
Joined
·
12,050 Posts
Have you lost brake fluid? If out of fluid is a no brainer.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
have not lost any fluid
 

·
Registered
Joined
·
609 Posts
IF you are getting an ABS and brake light and little fluid to your brakes....sounds like to me that your ABS thinks it has a skidding wheel(s) and is doing it's job...but not at the right time... (triggering the lights cause of input disagreement) I'd bet maybe something like a speed sensor or brake controlling solenoid valve malfunction...or similar....but just my $.02..if it were an aircraft...I'd say brake control valve or wheel speed transducer...
 
  • Like
Reactions: 01CTDbraaap

·
Registered
Joined
·
58 Posts
Discussion Starter · #8 ·
Sounds like a master cylinder.

Ops
had a fe3eling it was the master cylinder, gonna call napa today and see what they have.
thanks

AEdude1971
i went thru all of the sensors and there all reading on the ohm meter, but u are right that does sound like what it is doing, thanks
 

·
Registered
Joined
·
609 Posts
hopefully the MC works for ya... it'll be an easy fix....good luck... one thing though...resistance is one thing ...but is it the correct input??? i.e. skid=resistance no skid= open?? just a thought?? keep us posted...am interested to see what the outcome is..
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #10 ·
thank you much, on monday when i gotter n putter back on i'll let you guys know what happens, and as for resistance, do you mean on the sensors? or....? me and electrical do not get along:lol4:
 

·
Registered
Joined
·
609 Posts
I mean the sensors... I'm an aircraft mechanic by trade...and i specialize in electronics and electrical stuff...just be cause you have a resistance reading doesn't mean you have the correct input to the computer....sometimes a resistance reading can be the wrong input...just depends...a MC isn't a major expense...so see what happens...hopefillyit works for ya..
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #12 ·
ahhh ic i getcha now, well if the master cylinder is not the issue i will be goin back to the electrical, thanks for the advice sir :headbang:
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #13 ·
hello to anyone still readin this thread, master cylinder was the problem gotter on today n she stops perfect, although i still have the pesky abs and brake lights still on, anyone has a suggestion would be great. thanks for all the input you folks are the best. :blues:
 

·
Registered
Joined
·
609 Posts
bleed the brakes again...and again...till the lights go out...you have air trapped in your ABS control proportioning valve...i'd bet...
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #15 ·
ok will do
thanks :thumbsup:
 
1 - 15 of 15 Posts
Top