Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Premium Member
Joined
·
722 Posts
Discussion Starter · #1 ·
I put new rotors on the back of my truck and the parking brake pretty loose with the new rotors. The pads on my parking brake didn't look to bad. I adjusted the little star wheel to where it was tight and the pedal is tight but my brake doesn't hold very well. Any ideas?
 

·
Registered
Joined
·
1,378 Posts
Perhaps the new rotors had a little grease on them to protect from corrosion during shipping? If you didn't clean them I would take the rotors off and clean the little shoes AND the drum part of the disc. Wish I had disc. :(
 

·
Registered
Joined
·
73 Posts
Lucky A$$ with discs! Did you tighten the cable that run from the cab back to the E brake? I adjusted mine once and it worked wonders.
 

·
Premium Member
Joined
·
722 Posts
Discussion Starter · #4 ·
The E brake is tight when you push it to the floor. I didn't clean the rotors off i will have to try that thanks.
 

·
Registered
Joined
·
1,378 Posts
Clean your main pads too if you didn't clean the rotor at all! :) Almost all drum/disc manufacturers send their stuff out with oil or cosmoline or something to prevent corrosion. Tacky greasy stuff. It gets in the vanes in the rotors and makes weird smoke (no big deal) that can really freak you out when you warm them up the first time!:eek:hno:
 
1 - 5 of 5 Posts
Top