Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
What exactly does this mean, other than remove the emissions BS? My body has this code with no overhead message. Does it mean he needs to take it out and drive it on the highway for an hour? He's got an 08 auto.
Thanks guys
JW
 

·
Registered
Joined
·
1,229 Posts
is the light on? just drive it and see if the light goes out if its on or take it in to the dealership.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Yep, his lights on. It blows my mind how these trucks are so finicky. I've had my truck for two years and I've had only one check engine when I bought it for the 02 sensors. He's had his truck for a little over 6 months and has had two lights now. Granted I do drive about 60 miles on the highway more than him a day.
 

·
Retired Old Fart!
Joined
·
8,561 Posts
Yep, his lights on. It blows my mind how these trucks are so finicky. I've had my truck for two years and I've had only one check engine when I bought it for the 02 sensors. He's had his truck for a little over 6 months and has had two lights now. Granted I do drive about 60 miles on the highway more than him a day.
That is the difference. We all have differring driving styles and habits. I have a 50 mile round trip for work. All back roads at about 50-65mph. Almost like a slow freeway. I had almost no problems with mine. I started doing deletes just to improve the fuel economy.:thumbsup:
 

·
Registered
Joined
·
1,229 Posts
I have a buddy that bought one of the first 6.7's and he has never had one light and he gets 20+mpg, I called him the luckiest man in the world
 

·
Registered
Joined
·
83 Posts
What exactly does this mean, other than remove the emissions BS? My body has this code with no overhead message. Does it mean he needs to take it out and drive it on the highway for an hour? He's got an 08 auto.
Thanks guys
JW
I get the same code every once and awhile. clear it and its fine. Might have something to do with the exhaust falling off.:lol4: I dont think i am going to take mine to the dealer over it. If you get that code with the exhaust on you should just take it off, you will still have the same code, + more power and mpg:thumbsup:
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Thanks for the replies. He's got an appointment this coming Tuesday with the dealership where I bought my truck at. By the way, when I spoke to my buddy at the dealership he told me to go ahead and do the deletes. He said to keep all the stock parts in case something happens. Now I just need to start the endless research on the Smarty or the XRT. :headbang:
Thanks again
JW
 

·
Registered
Joined
·
13 Posts
I got this code today...drove 500kms no problem, took the truck into the carwash and there was the CEL. Anyone else have this code after deletes?
 

·
Registered
Joined
·
95 Posts
I did when I first installed my Smarty as my pressure sim wasn't making proper contact. I couldn't figure out why the Smarty wasn't keeping the code gone so I unplugged the pressure sim and reworked it and now all is good.
 

·
Registered
Joined
·
13 Posts
I'm running a H&S MM. I don't have any sims in...I wonder what the problem could be?
 
1 - 10 of 10 Posts
Top