Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1 (Edited by Moderator)
So a while back, i was driving my truck, (2004.5 ram 3500 nv5600), and the throttle started bucking for about 5 seconds and stopped but it left a code, i think p0220 or p0222, i pulled the exhaust brake and snipped the wire going to the apps wire, the previous owner spliced it right at the ecm plug. After that the code left the truck and everywas fine.

Today i was driving home and the throttle did the same. It was fine after that 5 seconds of acting up though. When i got home i checked codes expecting the same and i got a p2121 and p2122 instead, just wanted some input on what it could be, am i gonna have to dish out 500 on a sensor or wire harness at this point. Im not really comfortable messing with the ecm plug myself so thats not really an option. Most of anything id do is cut the wire at the ecm where he spliced it and but or soder it back together, i taped the bare end that i left behind by the way.(exhaust brake is going up on the classifieds lol)
 

·
Premium Member
Joined
·
6,693 Posts
Can/should try contact timbo Timbo APPS
Truck is 17+ years old, any brand older vehicle is going to have wiring/electrical issues.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Can/should try contact timbo Timbo APPS
Truck is 17+ years old, any brand older vehicle is going to have wiring/electrical issues.
Yeah I contacted him with the same info posted here via email, no response yet
 

·
Registered
Joined
·
8 Posts
Try running a second ground wire, from the battery to the engine block. But it could be a bad TPS/APPS or floating ground from the TPS/APPS to the computer. Genos garage makes a fix kit. My problem went away, but I have only put 200 miles on it so far. usually would have thrown a code by now though.
 

·
Premium Member
Joined
·
6,693 Posts
IDK, get harbor freight POS which can be free with coupons, just be very gentle on its' chinese leads or make your own.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
So it has happened again, p2121, no dead pedal then immediately jumps up way too high, its also now accompanied by a weird rough idle like its trying to stall, it happened this time when i was messing with my clutch (its not disengaging fully), and i started it in gear to move it, and it immediately took off obviously. Also recently i was replaced the oil cooler gasket and shorted the alt to the frame on accident (I know always pull the negatives) and it sparked a bit 😬. Could either of these caused it to resurface?
 
1 - 8 of 8 Posts
Top