Dodge Cummins Diesel Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
106 Posts
Discussion Starter #1
I’ve been getting these codes for years, I don’t always get the 0087 code. They occur when I’m pulling my loaded trailer, and under lots of stress(uphill, windy Ext..) I have ad165 lift pump, fuel rail plugged, egr, and dpf delete. Running H&S tow tune. She never misses a beat when the cel is illuminated, just really aggravating. The plug seems to have slowed the frequency of this issue, but I’d love to figure it out and fix for good.
Any advice would be great!
Thanks in advance
 

·
Registered
Joined
·
2,902 Posts
Check torque on the rail plug. Another guy on here basically gutted his whole fuel system only to discover it was just a loose pressure relief valve. Truck was acting like a tank venting issue, recurrent low rail pressure codes.
 

·
Premium Member
Joined
·
106 Posts
Discussion Starter #3
I will recheck torque, maybe I should also replace the oring, although it looked good.

And thanks for your Military Service!!
 

·
Premium Member
Joined
·
106 Posts
Discussion Starter #4
I still have these codes coming up, only when loaded and pulling hard. The rail plug is tight. Anybody dealt with this issue? 530k miles on it. Original stock injectors and cp3. Any suggestions on how to diagnose it? I don’t have gauges, so I’m not sure what my supply or rail pressures are when it happens.
Any thoughts?
 

·
Registered
Joined
·
3,911 Posts
My guess would be excessive injector return rates or cp3 but it's only a guess without rail and supply pressure readings.

By it's own right, 530k miles is awesome!!
 
1 - 5 of 5 Posts
Top