Dodge Cummins Diesel Forum banner

p0073 and p0107!

78276 Views 13 Replies 9 Participants Last post by  Hislop777
was wondering what that was about??
:confused013:
1 - 14 of 14 Posts

· Registered
Joined
·
155 Posts
I just had both the same codes come up on me today:banghead:

When I put the new exgaust manifold on, I didnt plug in (what ever it is) back into the cold air intake. So I did and reset some different #'s into the smarty and they were gone.:confused013:
 

· Registered
Joined
·
408 Posts
Discussion Starter · #4 ·
ok my bullydog fixed them for me.
 

· Registered
Joined
·
120 Posts
I get this and they clear with bullydog but come right back. Have removed bully dog and edge and they still come back. Any ideas thanks
 

· Registered
Joined
·
61 Posts
My 03 does kicks P0107 and goes on and off. I was told to ignore it. It wont affect performance or anything on the engine.
 

· Registered
Joined
·
120 Posts
Does when I get P0107. Been fighting this for about 2 months now. An ideas truck goes in limp mode. No power over 2k and the rail pressure is jumpy bounce from 7k to 20k with just a tap on the pedal.
 

· Registered
Joined
·
61 Posts
builttogame: check your boost pressure sensor and wastegate elbow. I had those symptoms and the elbow was clogged and boost pressure sensor was bad. Never kicked any codes related tho. All I had was an overboost code and p0107.
 

· Registered
Joined
·
120 Posts
i found the problem it was the intake charge temp sensor... the one that goes on the intake... it is a map sensor reads temp and pressure.. so i guess we have pre and post turbo maps sensors... talk to a tech and they do talk to each other and decided some fuel and timing... thanks guys....
 

· Premium Member
Joined
·
55 Posts
i found the problem it was the intake charge temp sensor... the one that goes on the intake... it is a map sensor reads temp and pressure.. so i guess we have pre and post turbo maps sensors... talk to a tech and they do talk to each other and decided some fuel and timing... thanks guys....
so how is this fixed just got it today...?
 

· Registered
Joined
·
23 Posts
i found the problem it was the intake charge temp sensor... the one that goes on the intake... it is a map sensor reads temp and pressure.. so i guess we have pre and post turbo maps sensors... talk to a tech and they do talk to each other and decided some fuel and timing... thanks guys....
Sorry to bring back old thread but getting the p0107 code recently on my truck as well .... at about 70 mph it will do a slight hesitate for split second then its fine . Anyone able to post a pic of the sensor they replaced ? What was the cost ? Being forloughed from my job id like to try and fix it myself to save few bucks
 

· Premium Member
Joined
·
2,430 Posts
Sorry to bring back old thread but getting the p0107 code recently on my truck as well .... at about 70 mph it will do a slight hesitate for split second then its fine . Anyone able to post a pic of the sensor they replaced ? What was the cost ? Being forloughed from my job id like to try and fix it myself to save few bucks
The sensor is in the intake on the head. Find a contact cleaner that doesn't affect plastics. Remove the sensor and clean it.
 
1 - 14 of 14 Posts
Top