Dodge Cummins Diesel Forum banner

101 - 120 of 183 Posts

·
Registered
Joined
·
1,189 Posts
Please keep us posted i was just about to hit the purchase button. He was quick to get back to me on the question i had. Maybe he's taking some time off.
In the 3 weeks from my purchase to getting my efi live, he never replied for a week. Assuming he was gone somewhere. But he had probably sold out of the autocal and because of covid, had to wait longer than normal for replacements. I also never sent him a bunch of emails that week. Just 2 I think.
 

·
Registered
Joined
·
2,959 Posts
I had $150,000 in credit fraud last year so i am jumpy with buying stuff online. I got a second card charge i think is related to the tuning order. Did everyone else get a second charge to their card?? It was @$25 and unexpected. But, i have never ordered from Canada before. Just want to know if the fraud is going again. My case was the biggest so far in my county to date.
 

·
Registered
Joined
·
178 Posts
I had $150,000 in credit fraud last year so i am jumpy with buying stuff online. I got a second card charge i think is related to the tuning order. Did everyone else get a second charge to their card?? It was @$25 and unexpected. But, i have never ordered from Canada before. Just want to know if the fraud is going again. My case was the biggest so far in my county to date.
I checked for you and I was only charged the initial $1,000.11 and nothing since.
 

·
Registered
Joined
·
2,959 Posts
Thanks. I called my bank. Its a fee for a foreign transaction. It is correct and not from the tuner. Just want to avoid all the fraud. My bank charged it.
 

·
Registered
Joined
·
2,959 Posts
Interesting. I haven’t used my card for anything this month except this purchase so it’s easy to see nothing extra on mine. Maybe your card company charges an extra fee for purchases out of country?
Your response beat my edit. It was a bank fee. Not the tuner. A fee for foreign transactions. Never paid that before and i get a lot of stuff from Chyyynnnaaaa.
 

·
Registered
Joined
·
178 Posts
Your response beat my edit. It was a bank fee. Not the tuner. A fee for foreign transactions. Never paid that before and i get a lot of stuff from Chyyynnnaaaa.
Good to know it’s not fraudulent! I can imagine how much that has to suck. Fortunately I’ve only been victim once and it was $100 that my bank refunded without question and issued a new card.
 

·
Registered
Joined
·
1,189 Posts
Give him the benefit of the doubt. Never know what happened. He could have easily forgot. I would call and see what he will do. Then pass that info on. Especially is someone else runs into the issue, it’s good to know there’s a solution.
 

·
Registered
Joined
·
178 Posts
My tuner is out for deliver today, still fighting with the shitbag scammers that I bought my exhaust and EGR deletes from. It's not a big deal at the moment though because I'm headed to the mountains with the 5th wheel on Thursday and then I have a big trailer to deliver next week so I'll wait until those are done before doing anything to the truck. That way if there's an issue I'm not screwed without my truck and loosing a vacation or loosing income. After next week's trailer is delivered I won't actually need the truck for a month or more so I'll plenty of time to do my install and address any unforeseen bugs that may appear. No fancy seats to worry about so hopefully there's no surprises. I'll write up a review on it after I get a thousand miles or so on the tuning which will only take a couple weeks.
 

·
Registered
Joined
·
67 Posts
I’ve had mats tuning on my truck now since April. I have heated seats (but not cooled). No issues with them, they work like they did before. I have no complaints thus far, no CEL/codes of any kind. Truck runs excellent. 19 3500 HO/Aisin 5 tunes SOTF. ( and for what it’s worth... his 12V tune.... well every time I turn it on... I go from “6 O’clock” to “high noon” if you know what am sayin”. Lol. Sounds KILLER.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,959 Posts
I’ve had mats tuning on my truck now since April. I have heated seats (but not cooled). No issues with them, they work like they did before. I have no complaints thus far, no CEL/codes of any kind. Truck runs excellent. 19 3500 HO/Aisin 5 tunes SOTF. ( and for what it’s worth... his 12V tune.... well every time I turn it on... I go from “6 O’clock” to “high noon” if you know what am sayin”. Lol. Sounds KILLER.


Sent from my iPhone using Tapatalk
So what HP are you running?
My tunes arrived yesterday. I will say service has been excellent and above what i could have hoped for. With as many questions as i asked him i am surprised he did not block me. Blocking me would have saved him a lot of time. I am probably why he forgot about the seat issue.
Now, i just got out from under the truck. Does anyone have a link or description on how to get the def injector off? I see how to unbolt it from the pipe but the connector is weird. Do we just leave the injector up there wrapped up?This stock exhaust is a travesty. Also, i never did a single recall or update so i think my ammonia sensor is still functional. So how do we address the def injector? Where is it best to disconnect and leave some parts on the truck? Or is it better to remove the whole def tank?
I also need a shibby plug kit if anyone knows the best place to purchase.
Also, is it best to leave a charger hooked up while flashing? If so which battery? The instructions say it takes 20 minutes like the v2 did. But, the v3 is supposed to be faster.
 

·
Registered
Joined
·
1,189 Posts
So what HP are you running?
My tunes arrived yesterday. I will say service has been excellent and above what i could have hoped for. With as many questions as i asked him i am surprised he did not block me. Blocking me would have saved him a lot of time. I am probably why he forgot about the seat issue.
Now, i just got out from under the truck. Does anyone have a link or description on how to get the def injector off? I see how to unbolt it from the pipe but the connector is weird. Do we just leave the injector up there wrapped up?This stock exhaust is a travesty. Also, i never did a single recall or update so i think my ammonia sensor is still functional. So how do we address the def injector? Where is it best to disconnect and leave some parts on the truck? Or is it better to remove the whole def tank?
I also need a shibby plug kit if anyone knows the best place to purchase.
Also, is it best to leave a charger hooked up while flashing? If so which battery? The instructions say it takes 20 minutes like the v2 did. But, the v3 is supposed to be faster.
Welll...... weekends almost over..... how long did the tune take to upload? How long was your first black strip?
 

·
Registered
Joined
·
2,959 Posts
Does anyone have a link or know what to unhook under the hood. The truck is done and i want to make sure i did the under hood stuff right. Egr is in place but turned off. Egr will be completely removed soon.
I unplugged from the drivers side 3 plugs. They were the throttle valve and two on the egr stuff drivers side. Likely the egr valve and a pressure or temp sensor. Thats those three.
I did one plug for what i think is the egr motor on the passengers side. Is there more than one connection on the passengers side that needs to be removed?
Or can all these plugs stay plugged in for a proper visual.
I am having trouble finding instructions.
The shibby plug kit came with a warning that on a 15 two of the egt covers would need to be modified. I did not modify. They didn’t snap on but fit snugly so i taped them.
 

·
Registered
Joined
·
1,189 Posts
Go on optimals YouTube page. He has a video of removing it. Basically whatever you remove if you were to delete your egr, is what gets unplugged.

It has to stay unplugged as far as I understand.
 

·
Registered
Joined
·
2,959 Posts
The tune took 7 minutes to upload. I flashed the truck then some tuners want the truck started to make sure it will start before removing anything. Well, i about died when the truck started and idled like total crap. It had an idle lope like a tractor and was hard to keep running. It sounded like Double R Diesels lope tune but with a bad idle and a misfire with a 12v sound all in one. The throttle was not responsive. I did not put it in gear or move it. I then checked that a tune was flashed and it was. I then started it again for 5 seconds and the same lope. So i called and emailed the tuner. He responded by email in ten minutes that the truck was not to be started until the dpf was out. I was skeptical but removed everything anyway. After everything was removed there was no issue on the next start.
Wow, the 20 hp tune is just a bit stronger than factory. No smoke at all. Zero. NOTHING. I tried to get some smoke on purpose and zero smoke even when trying to lug it down. The throttle is great and the Aisin is like it was before. I then switched using the autocal to the 75 hp tune. This is the one i plan to use. The truck rips now and throttle tip in is amazing. It pulls hard. Very hard and smooth. This tune only has about a one second puff of light smoke then it takes off with no smoke. The truck runs amazing. I cant feel the Aisin defuels on the shifts at all. It feels exactly like before but smooth through the entire power band. THE TRUCK SOUNDS AMAZING. An emission compliant tune will never sound this good. The exhaust brake is louder. Much louder. The idle just pounds. It sounds so amazing i cant emphasize that enough. I have the regular Cummins idle. Not the jet idle. I don’t like the jet sound so specified that in the purchase instructions.
The truck smells amazing. I hated the burning piss smell and it made the kids nauseous and asthmatic. Infact i have puke jars in the truck for this smell for the kids. The regen also made them sick if it was blowing back towards the truck when at stops. The delete smell doesn’t bother them and never did with my past trucks. This is a huge win in the family department. Much healthier.
The dpf/scr/doc were easy to take off. Like way easy. No binding no struggle just unbolt one at a time and lube the exhaust hangers with wd 40. I removed the hangers with channel locks and my hands. They slid right off.
The p1 MBRP 4” down pipe back exhaust did not fit. It was the correct part number and was for a 3500 but the tail pipe from the factory that gets reused didn’t line up. The instructions say the pipe needed to be 39 1/4” long. It was. I had to cut the kit pipe to 20 1/2” to get it to fit.
Anyway i wish i did this 5 years ago. Anyone wondering and worrying about the tuner we are discussing need not worry. It is all great. After sale customer service has been great.
 
101 - 120 of 183 Posts
Top