Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
1,526 Posts
Discussion Starter · #1 ·
after i installed my twins i had a couple bad oil leaks, so once i got them stopped i checked my oil and it was about 3inches above the full mark :thud: i know i didnt over fill it when i changed it!!! :CRY: so probably a bad injector you think?? coolant level is still good
 

·
Registered
Joined
·
1,119 Posts
dang sounds like a bad injector for sure. Probably cracked body or tip. Sorry to hear it good luck.
 

·
Registered
Joined
·
224 Posts
Did you change the oil before you did the install? Does it seem to be running fine? If it seems to be running good I'd change the oil and then keep an eye on it.
 

·
Registered
Joined
·
1,526 Posts
Discussion Starter · #4 ·
Did you change the oil before you did the install? Does it seem to be running fine? If it seems to be running good I'd change the oil and then keep an eye on it.
yeah the truck still runs great... smokey on bottom but its been like that since i got my smarty
 

·
Registered
Joined
·
131 Posts
It leaks fuel into the cylinder, washes through the cylinder into the bottom end, and fills up the crankcase. At least that I how I understand it. I haven't had that problem yet fortunately.
 

·
Registered
Joined
·
1 Posts
Yep thats what happens bad injector can not atomize fuel so it stays liquid and compression forces it pass the rings in to the crankcase.This will cause cylinder liner,ring and piston failure. Take injectors to the pump shop and have them pressure checked if they are breaking out good then you probably have a bad seal in the pump
 
1 - 7 of 7 Posts
Top