Dodge Cummins Diesel Forum banner
1 - 12 of 12 Posts

· Registered
1991 Dodge D350 a518 auto, 3200 spring, pump turned up, timing advanced.
Joined
·
331 Posts
Discussion Starter · #1 ·
I just put my 5" turbo back exhaust on my 09 6.7 dually about 4 days ago. Last night I was looking into the tip and noticed that there was some oil in the exhaust pipe and the bottom of the tip. I checked my oil and it's still good in the motor. I'm just wondering what could be wrong

I have it fully deleted and running the XRT programmer. I also did the crank case filter delete that I found on here about a month ago.
 

· Cowboy AKA Equality State
Joined
·
1,078 Posts
Sounds like time to replace the turbo.
 

· Registered
Joined
·
320 Posts
possibly bad exhaust valve seals ?
 

· Registered
Joined
·
180 Posts
It's more likely grease in the new exhaust melting and mixing with the soot and making it look like oil. Give it. Mine did the same thing for the first 2 weeks I had the exhaust on. Keep it hot and keep driving and it will go away soon enough
 

· Registered
1991 Dodge D350 a518 auto, 3200 spring, pump turned up, timing advanced.
Joined
·
331 Posts
Discussion Starter · #5 ·
Thanks red that makes me feel much better. I guess I'll just keep driving it and hopefully it'll clear up. Like I said all the oil levels are good so I don't think I'm loosing any
 

· Registered
Joined
·
98 Posts
When I first did my delete, I had only a dpf delete pipe started the truck up had oil splatter on the wall in the garage. Ran it for a couple weeks and stopped doing it. Never had it again until I traded it off 50k later. Keep an eye on it but should be fine . I did the paper towel test in front of the exhaust and nothing came out.
 

· Registered
1991 Dodge D350 a518 auto, 3200 spring, pump turned up, timing advanced.
Joined
·
331 Posts
Discussion Starter · #8 ·
I haven't smelled it yet but yes I did put a flo pro on it. Is this common with those systems? And will it burn off?
 

· Premium Member
Joined
·
11,939 Posts
Is you mixing 2 cycle oil in the fuel for lubrication??
 

· Registered
Joined
·
1,468 Posts
I had the splatter shortly after I did my flo-pro delete pipe. I have an axle dump and it was spraying all over my driveway.



Put my hand under the tip and sure enough it was spraying black residue at idle.


 

· Registered
Joined
·
63 Posts
Are you sure it's oil? My exhaust came lubed up on the inside and it mixed with the soot and dripped out like that. May not be it but I'd check that before spending money trying to find a solution


2008 bone stock.

Sold: 2001 QCSB slt 6 speed. 2.5 inch leveling kit. 18 inch Motometal rims with 35 inch terra grapplers. 150 hp injector and raptor lp. Afe stage one cold air intake. Edge comp box. Four inch straight pipe to five inch tip. Garrett s300 single turbo. Cowled hood and of coarse a cummins C shift knob.
 

· Registered
Joined
·
594 Posts
I only get that splatter when i rinse out the rear portion of the exhaust when i wash the truck. It goes away. Also remember that with the truck deleted, you are sending a lot more of that soot out the tail end and its so fine that when it hits your hand or paper towel that it will look like a liquid splatter if a "clump" of it spits out.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top