Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Premium Member
Joined
·
198 Posts
Discussion Starter · #1 · (Edited)
Driving home my truck died with no warning. No check engine light no sputtering just silence. First thought was VP44. Scanned the truck with a Snapon scanner and no codes. I have fuel pressure and I have fuel to the VP44 but no fuel on the other side. Pulled the pump and sent it in to Industrial Injection and the pump is perfect. The VP44 did have 2 codes, one was crank position sensor { i think they ment cam sensor } and the other code was ECM. If the cam sensor was bad would the scanner still show rpm's? Does this sound like the ECM took a dump?

Any thought's????????????????
 

·
Registered
Joined
·
1,213 Posts
Sounds like the ECM poo'd.

If the cam sensor was bad, NORMALLY the scanner could not read RPM, but, it may just be flaky, and show up on the scanner but not be accurate enough for the ECM.

Look on ebay for an ECM. They are very pricey new.

You should be able to pick an ECM up for around $300, or over $1k at the dealer :thud:

Merrick
 

·
Premium Member
Joined
·
198 Posts
Discussion Starter · #4 ·
Also there were no signs of the sensor going bad, like a tach bouncing around or engine missing.
 

·
Registered
Joined
·
1,213 Posts
Check the ground on teh ECM, I think it's pin #11, but it is looking more and more like teh ECM...

Merrick
 
1 - 5 of 5 Posts
Top