Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have cleaned all the terminals, replaced the alternator with a good bench tested one, replaced the alternator fuse, and even wired up an external voltage regulator. I have tried everything I can think of and am still getting no voltage out of my truck. Any advice would really be appreciated
 

·
Registered
Joined
·
314 Posts
Look at the brushes.
you can buy just brushes on ebay
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I’ve actually put three new alternators in and the last one I had tested at three different places. I think it’s something stupid somewhere that’s causing my issue but for the life of me I can’t figure out what
 

·
Registered
Joined
·
314 Posts
I have read the PCM adust the charge rate ?
 

·
Registered
Joined
·
18,904 Posts
The PCM does the regulation when operating correctly and is hooked up. If a properly wired external voltage is hooked up it should work fine unless you got a bad in the box alternator, but you tested it so that should not be the case. So most likely you are wiring them wrong. Go back and make sure the proper hot wire is has 12 volts with the key ON and the ground wire to the external regulator is grounded well. Three wire regulator works better than a 4 wire one. Ground regulator(proper wire or body of it. One 12v hot wire going into regulator and one out to alt. ground from alt through regulator. Was there not an instruction page in the box? If not search out one on line with the same wires or part number.
 

·
Registered
Joined
·
242 Posts
Not trying to sound like an a$$, but what condition are your batteries in? Maybe they're bad and just won't accept the charge?
 

·
Registered
Joined
·
18,904 Posts
Good thought. OP, What is the dash voltage when running?
 
1 - 8 of 8 Posts
Top