Dodge Cummins Diesel Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
I will know tomorrow, it got dark on me tonight when I was trying to check it, but it has been giving me trouble for the last week, with the WTS start light not coming on after it would act up and stall, and I would wait for a while, and finally get the WTS to come on, then the pump would run and the truck would start, I just put a Blue Chip VP44 on it today, it ran great for about 10 minutes, then back to acting up, and now the WTS will NEVER come on, and the pump will not run at all, but it will start, I guess because the VP44 is new, and the internal pump in it is strong enough to make it start and keep it running. But because the WTS light is not coming on, I am thinking the ECM is not sending the signal to the pump
 

·
Registered
Joined
·
13,340 Posts
Your ECM is dying.

Slow to light WTS means the ECM is starting slowly. The WTS is the first thing the ecm activates so it is a good indicator of the health of the computer.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
That's what I have been seeing a lot through all the research I have been doing for the last week. The VP44 was weak too though, because one time when I hot wired it it, it still wouldn't start. I think the ECM is bad too, but I wish there was a way to know for sure
 

·
Registered
Joined
·
13,340 Posts
The wts light not coming on is telling you.

The vp44 has no jurisdiction on the wts.

Upon booting up the ecm turns on the wts light first. Without a wts the ecm isn't on
 

·
Registered
Joined
·
13,340 Posts
If the vp44 also didn't work when hot wired then I would think both are bad.


Clean and grease EVERY connection under the hood with dielectric grease. Ensure that all connections are good.

But I am guessing you will need to pony up a good bit of money
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #11 ·
Thanks, I'll check the power to the ECM today, I'm sure it is good though. I haven't found any power issues, wiring problems, or any corrosion in any plugs, or anywhere else in the truck. Now if I can find an ECM around here (central Florida) then get it flashed all in one day, maybe I can get on the road! Lol
 

·
Registered
Joined
·
197 Posts
Check Auto Module Source in Davie FL.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #13 ·
Thanks, I found them earlier when doing a search, but they are 246 miles south of me :( Trying to find a good used one right now, I know that's not ideal, but I'm getting close to a deadline on this delivery and pick up I have to do
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #15 ·
it is the original OEM lift pump, but the WTS light has been intermittently not coming on, and when it wouldn't the lift pump would not run either. the WTS light never did come on when I turned the key on before, even when it did work, but it has been delayed for a long time, it would not come on till all the other dash lights went out
 
1 - 20 of 25 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top