Dodge Cummins Diesel Forum banner

No TPS

791 Views 4 Replies 3 Participants Last post by  Philip
ok so i have a 91.5 w250 auto with the 727 torqueflite and there is no TPS on the injection pump.
The owner before me told me it wasnt the original tranny but it is the same as stock because i just changed the tranny filter/fluid and i bought the filter for the stock tranny and it was the same as the old one.
Is this a problem? The tranny shifts late at WOT from first to second.
Any help is appreciated
1 - 5 of 5 Posts

· 1ST GEN
Joined
·
11,549 Posts
A TPS is only used on a later model 1st gen with an OD trans and a PCM.

Shift points are controlled by TV cable adjustment. I am not ure if your nonIC TV cable adjusts the same as a IC trans does. I'll let someone with a 727 tell you how to adjust your TV cable.
 

· Registered
Joined
·
339 Posts
may not have been the original trans I think is what he ment, do you know if the trans had a shift kit installed?? and or if the govenor in the trans was changed as well?? certain stages of shift kits will allow the shift points to be held longer and override the factory govenor shift point by not allowing the fluid to get to it due to the new shift valving that may have been installed in the valve body. or the throttle pressure cable is out of adjustment there should be a sticky here some where on the adjustment proceedure hope this helps :)
 

· Registered
Joined
·
44 Posts
Discussion Starter · #4 ·
So if i dont have the overdrive transmission then there is no TPS? and my truck is IC
 

· 1ST GEN
Joined
·
11,549 Posts
If your truck is IC'd it should have an OD trans unless someone changed it out.

Look in the driver side of the trans. In front of the rear cooler line facing upwards towards the bottom of the cab. Is there a two wire plug going into the trans case?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top