Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your truck HERE to be a part of December's Cummins of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So my pickup was running great, took it to the store on sunday, made it home just fine. A few hours later and she wont start now.. I have done a little poking around, mostly some electrical testing, I started with this because when you turn the key, normally you would hear the lift pump start to pump fuel to gain pressure, however with mine all you hear is a click. I have tested the relay, it was fine, the prongs on the relay were clean, I have power going to my lift pump and to my injection pump. What really stumped me was I only have 8 volts going to my lift pump.. That's not normal is it? I figured it needed 12 volts to run, but after the key is on it holds a constant 8 volts. Any ideas on where to look or has anyone had similar problems?
 

·
Registered
Joined
·
2,192 Posts
Lift pump might be shot or froze up. What kind is it? If it has a water seperator when was the last time you drained it?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
As far as I know its the stock lift pump, there is a water separator on the frame as well as a aftermarket inline pump. I have a fuel pressure gauge as part of my pillar mount, and I had 20psi of fuel pressure yesterday when i made it home.
 

·
Registered
Joined
·
2,178 Posts
Your lift pump is controlled by the ECM, the ECM does the prime with key on. You should have 12volts going to the pump, Make sure all the connections are tight and clean. How about the wait to start light? If it doesnt come on anymore is a tell tell sign of a ECM going bad. Make sure all your grounds are clean, there is a ground on the driverside of the block that is just for the ECM itself.

Does the engine turn over still?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Yea the wait to start light still comes on and yea it turns over like a son of a . I have also noticed that when driving, at higher rpms,it seemed sluggish and like it had poor throttle response.
 

·
Registered
Joined
·
2,178 Posts
Is that the stock fuel system? If so id toss that anyways and get something better for your truck.
 

·
Registered
Joined
·
985 Posts
Is that the stock fuel system? If so id toss that anyways and get something better for your truck.
I second this. 20psi out of a stock LP is impressive. But toss that thing and get yourself an aftermarket. I'd recommend FASS. Your VP is taking a beating with that stock pump.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
145 Posts
I second the comment to upgrade ur fuel system but for now, with key on ur lp should run for 4 to 5 seconds and stop then if u bump the starter it should run for 30 seconds ... If u can't hear ur pump run at all under have a prob...
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
Its not a the stock fuel system. The guy I bought it from installed one of those Carter pumps inline with the tank and stock lift pump. I don't know if he wired that pump into the same circuit as the stock lift pump or not.
 

·
Registered
Joined
·
2,178 Posts
:doh: like we said rip that two pump mess out. There isnt any need for two pumps, you are asking for problems like you got now.
 
1 - 10 of 10 Posts
Top