Dodge Cummins Diesel Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #21
he said i have the wrong map sensor in my truck and that i need to change the wire harness pigtail. it seems hard to believe nothing looks to be tampered with from the factory
 

·
Registered
Joined
·
247 Posts

·
Registered
Joined
·
247 Posts
he said i have the wrong map sensor in my truck and that i need to change the wire harness pigtail. it seems hard to believe nothing looks to be tampered with from the factory
Sounds BS to me
 
  • Like
Reactions: 01extended

·
Registered
Joined
·
247 Posts
ok, ok, ok. One web side says pigtail and another no.Call PDP and ask them.Dealer wants 600 to install
 
  • Like
Reactions: 01extended

·
Registered
Joined
·
247 Posts
Okay here is my opinion on the pigtail thing. The original Map/Turbo Boost sensor is no longer available. Cummins has a Map sensor that works for the engine but the connector is not compatible in some Dodge applications. The pigtail is what make this map sensor fit the dodge harness but I don't know which years need the pigtail and which don't, I have no 1st hand experience with this issue. The original Mopar part is not available so they (the dealer) must be using the Cummins part and they may be right about the pigtail for your 2001.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #28
I got a Camshaft sensor pigtail and put it on. also got a multimeter and checked voltages. got everything from orielys for just over 100$. everything works great no and no check engine light heck yeah! thanks for you time and motivation to help me get past this problem! much appreciated.
 

·
Registered
Joined
·
247 Posts
I got a Camshaft sensor pigtail and put it on. also got a multimeter and checked voltages. got everything from orielys for just over 100$. everything works great no and no check engine light heck yeah! thanks for you time and motivation to help me get past this problem! much appreciated.
Glad you got it going. (y)
I guess that you used the same sensor you already had but added the pigtail?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #31
@maxwedge572 I replaced the Pigtail and the Sensor. The sensor that was in there was not even for my truck lol and the pigtail contacts were destroyed from someone prodding them with there multimeter tips. All is well now!
 
21 - 31 of 31 Posts
Top