Dodge Cummins Diesel Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
1,086 Posts
Discussion Starter · #1 ·
this is my buddys 05 cummins,
he was running it yesterday and it ran fine then later on in the day he went and started it and he said the idle was a little ruff, then once it got warmed up it was fine, then he drove out and the thing was pouring smoke out and he could barly get up the hill so he pulled over and he said the idle was really ruff and had to hold the pedal some to keep it idling, idling ruff, no power. lots of smoke, he let off the pedal and it just stalled and he never tried to start it again. the truck has a bully dog power pup, intake and a 5" exhaust. what do you guys think the problem might be?
 

· Registered
Joined
·
2,289 Posts
Take the BD off and check for codes by using the key trick. Could be just a hiccup with the BD. Could be a popped relief valve on the rail.

Can he read the rail pressure with the BD?

Randy
 

· Registered
Joined
·
119 Posts
what is the key trick?
 

· Registered
Joined
·
119 Posts
oh thanks where can i find out what the codes mean?
 

· Registered
Joined
·
119 Posts
thanks for the info!
 

· Mr. Vehicle Destroyer
Joined
·
12,391 Posts
if it isn't injector related down on power and heavy smoke is usually an indication of a boost leak. you said it is an 05 and that year dodge did an experiment on the plastic intercooler. The plastic end tanks blow out all the time and are usually replaced under warranty if you take it to a dealer. If not the intercooler it still definitly sounds like a boost leak of some form. Check the boots and clamps to make sure they are tight
 

· Registered
Joined
·
753 Posts
my truck has done that before. It ended up being the programmer. Reinstalled the program and everything was good to go
 

· Registered
Joined
·
1,086 Posts
Discussion Starter · #12 ·
update, ok i went to my buddys place and we set the bully dog back to stock. then we started her up and it seemd to run/fine. some white smoke then it stoped. so we just went for a little drive around the yard and it seemd to be smoking white. when we started it there was no engine light on, but as soon as he toched the pedal the light came on. we shut her down and check the codes and it read P0633, P0483, P0341, P0340. we then reset the codes with the bully dog and started it up again, souded good, then it kinda had a little miss then idle fine, no smoke really at idle so he took it for a other drive around the yard. but still the white smoke. i checked for boost leaks and couldnt find anything and i check the oil for diesel and none in it. i took the oil fill cap off when idling and seemed to be not much blow by. then i checked the crankcase vent and there seemed to be a lot of oil under there and seemed to be a good bit of air/white smoke coming out of there. truck seems to sound good. any ideas what this could be?
thanks for the help
 

· Registered
Joined
·
345 Posts
It has something to do with that camshaft position sensor i would be willing to bet we had a customer who refused to swap to another programer from bd and it was an 05 also we just recently swapped hers out for the same issues after seeing the same codes it takes 5 minutes to do. Then we checked with the drb again and did and injector cut out test to verify all was good and its been running fine since.
 

· Registered
Joined
·
1,086 Posts
Discussion Starter · #14 ·
what did you swap out, the camshaft sensor? and what would cause the smoke coming out of the crankcase vent. and how much air should be moving throught that vent?
 

· Registered
Joined
·
345 Posts
that however sounds like an injector problem first thing I would do is pay $75 bucks to have dodge dealer do a scan test on injectors by killing each injector while the truck is running if the injector being cut out changes the way the truck idles then that injector is an issue. I would then have them do a compression test on the truck to make sure no cylinder has been washed out. But the truck just wouldnt run worth a dang with the bad sensor and fuel mileage was nowhere to be found little white smoke and rough idle no smoke coming out of crank case vent which indicates to me compression problems and bad injectors. DONT drive it any more then you have to until the problem is located.
 

· Registered
Joined
·
1,086 Posts
Discussion Starter · #16 ·
so i should probly start with the cam positioning sensor first, then check the injectors if it not complete cured?
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top