Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
It seams as though I have no power when towing my horse trailer (apx 7750 LBS empty, 10500 loaded.) up hills. I have to shift into 4th gear sometimes and crawl, with no boost (no leaks that I know of), at 210*-215*, exhaust at 1000-1100.
- 4th gear at 45mph, 2000-2200 rpm.
If I punch it, I have boost, but the exhaust shoots up to 1300-1400.
Then, unloaded up hills 5th gear is fine, 55 mph, 2100 rpms. and I have power, but temp still goes up to 210*, EGT @ 900. High RPM 2500+ results in raised engine temp.

2005 Ram 3500, manual. 167K miles. Stock 17 rims, 10 ply tires. No tuner. Exhaust brake, but doesn't work. No intake mods. Elevation apx 4750-5000. Outside temp apx 90-100. I don't know what size rear end.

Is this normal or do I need to fix something I don't know about. I have replaced the thermostat with a Cummins 190* and flushed it in June. Should I do a fan clutch? Exhaust manifold? Radiator? Should I and how do I check for boost leaks?
 

·
Registered
Joined
·
1,843 Posts
Check your air filter.
 
  • Like
Reactions: rghavana

·
Banned
Joined
·
1,096 Posts
What year truck, how many miles, what speed, what rear end, what tires, does it have a tuner, what elevation, any boost leaks that you know of, last coolant flush and thermostat change, any intake or exhaust mods, what were outside temps, what’s the weight of the trailer........ This is stuff we need to know to assist you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
What year truck, how many miles, what speed, what rear end, what tires, does it have a tuner, what elevation, any boost leaks that you know of, last coolant flush and thermostat change, any intake or exhaust mods, what were outside temps, what’s the weight of the trailer........ This is stuff we need to know to assist you.
- Thanks, I updated the post with the info you asked for. Hopefully that helps.
 

·
Banned
Joined
·
1,096 Posts
Sounds like coolant temps are in a good range being that hot, I’d still check for boost leaks. Your egts arnt to crazy and you can run 1300 all day. Other than that it does sound to bad.
 

·
Premium Member
Joined
·
6,693 Posts
Clear air intake/good filter?
clear radiator/coolers?
Make sure exhaust brake is not blocking exhaust?
 
1 - 6 of 6 Posts
Top