Dodge Cummins Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
Its been cold the past few nights (-25*F) and the day temps barely making it to 5*F. I go to use my truck last night and after i started it go to put on my headlights. Thats was a NO GO. cab lights, dash lights, parking lights and fogs all come on except the headlights themselves. Thought it was the bulbs, replaced them and... nothing. At work thinking about it right now, going to try replacing the switch and see if that works.

Any other suggestions?
 

·
Registered
Joined
·
135 Posts
Discussion Starter #2
so my girlfriend just tried my lights out, turns out the high beams work and lows DO NOT, also my blinkers do not work.

Just an update but still looking for some suggestions
 

·
Registered
Joined
·
1,981 Posts
still sounds like the switch in the column
 

·
Registered
Joined
·
7,018 Posts
ok, i had a problem like this and it was my headlight switch. Also see if there are any fuses or relays bad.
 

·
Registered
Joined
·
889 Posts
i had this problem in my old cummins and have this problem now in my current one, pull the headlight switch out and unplug it, look at the plastic box lookin deal with all the wires coming into it, there was one part melted on mine, so friday im replaceing that pig tail and the switch
 

·
Marble Crusher
Joined
·
1,857 Posts
agreed with the headlight switch had to replace the one on my 01 at work and it was doing the same thing.

-Jordan-
 

·
Registered
Joined
·
108 Posts
I had this exact problem, it was the combination switch in the steering column. it is the stalk on the left side of the steering column that controls the wipers/blinkers/hi-lo beam/flashers. part is available from advance auto, was about 60$, need some torx bits to get the plastic housing of the steering column off, and get the switch out. I just replaced mine, but I took my old one apart and found that where the contacts rest inside the switch for the low beams there was a corrosion buildup or a burn spot. cleaned it with a small piece of sandpaper and good to go.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #8
whats wierd is that I tried it yesterday when i got home and all of a sudden the low beams work, my blinkers work (drivers side is a little fast) but it worked a few hours later then when my girlfriend tried.. Wierd Im going to take a look on friday my day off and try both switches.

Thanks guysfor the second opinions!
 

·
Registered
Joined
·
108 Posts
No that's exactly what mine did. If you cycle the switch a few times you should see that it can work and the next time not. Just pull your combo blinker switch take it apart you will see the burnt contact right away. Lil sandpaper and some dielectric grease and u be good to go.
 

·
Registered
Joined
·
23 Posts
Multifuntion switch on the collumn. Had the same prob to the t. Makes for a scary drive in the backwoods when it fails, dont ask me how i know.
 

·
Registered
Joined
·
889 Posts
i just replaced the headlight switch and the plasic peace with all the wires on it and it works fine now, any up dates? did ya get er fixed?
 
1 - 12 of 12 Posts
Top