Dodge Cummins Diesel Forum banner

New ECM defective??

1922 Views 6 Replies 3 Participants Last post by  sebiscut
I just replaced the ECM in my 02 that was running really erratic & thought maybe it was the injection pump, too. THe pump tests fine, so I bought a reman ECM from Auto Computer Exchange in Florida & it ran fine for 3 hrs, restarted it & it ran rough. New code shows PO606 which means bad ECM. I removed the Edge EZ thinking maybe that caused the ECM to go bad, but same code shows.
Anyone have a similar problem or idea of what could cause the ECM to go bad?
1 - 7 of 7 Posts

· Registered
Joined
·
4,160 Posts
they better not be crooks i just bought a ecm from them for my dads 02
 

· Registered
Joined
·
42 Posts
Discussion Starter · #4 ·
Those guys at Auto computer exchange are crooks and sell bad computers then give you the run around on exchange.:confused013:
The ECM I got from them went bad after 3 hrs of running, but could be a short somewhere in the truck causing it. I called ACE & they're exchanging the box & also wanted to check my PCM, so we sent that, too.
I just did a google search on them & looks like the BBB has a lot of complaints on them & their rating sucks. If I get the runaround or another bad ecm, I'll call my VISA provider & dispute the payment.
 

· Registered
Joined
·
5 Posts
I really hope that its goes better then its going for me. I am in the middle of a dispute with them right now. For a computer i never even gave them permission to order. So i sit here now with a over 700 dollar charge for and 02 cummins ecm that i never even ordered from them . They told me there was a refund being put back on yeah well thats yet to happen.
 

· Registered
Joined
·
5 Posts
Finally I got my money back. Don't just look at BBB look at the reviews. I have seen storys like yours with computers being hooked up for 2 days or shorter and the computer taking a . Things not being programed into the computers like they should. I have also seen people have havee good luck bt only a few.
 

· Registered
Joined
·
42 Posts
Discussion Starter · #7 ·
Finally I got my money back. Don't just look at BBB look at the reviews. I have seen storys like yours with computers being hooked up for 2 days or shorter and the computer taking a . Things not being programed into the computers like they should. I have also seen people have havee good luck bt only a few.
I read quite of few feviews from ticked off customers as well as the BBB's "F" rating. I sure hope I din't get hosed, too. Talked to their tech this morning & he says one of the major causes of ecm voltage spikes is due to low batteries. Says it takes em out every time & thyat I needed to replace both batteries before putting the ecm back in. Never heard that before. Anyway, we'll see inj the next few days.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top