Dodge Cummins Diesel Forum banner
1 - 16 of 16 Posts

· RVer
Joined
·
34 Posts
Discussion Starter · #1 ·
I have a 1999 Dodge Ram 24 valve turbo, auto, 4 inch stainless exhaust, new fuel filter and feed pump, edge and monitor. After truck is driven for 20 minutes on highway I experience a loss of power at 2100 rpms around 55-60 mph. After feathering the gas pedal I can get power back briefly but when heated up again it starts all over. Truck runs like a bear off highway.Fuel pressure is steady at 10. Mechanic got a code showing fuel timing problem and had no idea. Any hep would be great. Problem happens with and with out a load. 70 k on truck. Bill
 

· SuperDuperMod
Joined
·
2,408 Posts
do you know what code it was specifically?
 

· RVer
Joined
·
34 Posts
Discussion Starter · #3 ·
sorry, no. just written on invoice along with a map sensor notation. I unplugged the Edge and still experience the problem
 

· Registered
Joined
·
1,816 Posts
Is this problem intermittent, or does it always happen at the same RPM?? It would definately help to know the exact code number, then we can help you out from there.
 

· RVer
Joined
·
34 Posts
Discussion Starter · #5 ·
sorry for delay

I was able to retrieve the codes documented and they are as follows;PO216 inj pmp tim fail and PO237 map sensor volts too low. Any help would be great, the kids want to camp but I am hesitant to tow right now. The issue only occurrs after 20 minutes of highway drive time or 15 miles of warm up driving. Seems to happen at the overdrive point of RPM. I can't maintain 55 - 60 mph with out losing the pedal.
 

· Registered
Joined
·
1,816 Posts
Someone will correct me if I am wrong, but I believe that the PO 216 code is really bad news, and usually means it's time for a new injection pump, as for the other, if the pump is causing that many problems, it might have trigered the other code??? Not to sure on that second one though. I'm sure that someone else will chime in here!!
 

· Registered
Joined
·
191 Posts
you are correct the first code mean ahh CRAP!!!:CRY:.......so no camping till she gets a new pump:$:
 

· RVer
Joined
·
34 Posts
Discussion Starter · #8 · (Edited)
ok,thanks

:beerwould it be unusual for the pump to act up only after a warm up drive. It does not act up at all around town. My EDGE shows fine fuel pressure too. Its all new to me. Just looking for moral support I guess before I reach for the green!!
 

· Registered
Joined
·
1,816 Posts
I have heard that the code listed is internal failure of the pump, and it's only a matter of time before it does fail. On the bright side of things, they have gotten increasingly cheaper since a couple of years ago, and if you post a wanted to buy thread on this forum, it's like pricematching at it's finest. A lot of the guys on here have bought and replaced them, so if there is a deal to be found, I'm sure someone can point you in the right direction. If it were me, I would not tow until it is replaced:thumbsup
 

· RVer
Joined
·
34 Posts
Discussion Starter · #10 ·
making sense

I thought I was in the clear when I replaced the lift pump and my fuel pressure was good. I guess the damage was already done and is starting to show now... At least I hope my limited knowledge makes sense!! I will ask around to find a new pump on the forum. You all have been helpful to a beginner such as me. The truck has been good to me since 99 so I guess this is an investment.. Thanks all. Any advice is still welcome
 

· Registered
Joined
·
1,816 Posts
If you do a search on this forum as well there are a ton of good how to write ups on all sorts of things, if look, I'm sure you will find video's and what not on how to replace the pump, etc... Good luck
 

· RVer
Joined
·
34 Posts
Discussion Starter · #12 ·
Will do, I saw the video how tos. I like your headlights. I just put them on mine. Thanks again
 

· RVer
Joined
·
34 Posts
Discussion Starter · #13 ·
good advice or referral for good Injection Pump wanted

:butt: I hope I am requesting info in the correct forum.. If anyone has had a similar issue with a possibvle bad injection pump, I am looking for advice on an after market pump for a 99 Dodge Ram 2500, 24 valve CTD. I have the EDGE w/monitor along with a new lift pump, filter and 4"exhaust. Truck used to tow a 30ft fifth wheel RV in spare time. Looking for reliability and compatability. Any advice or referrals would be greatly appreciated.
 

· RVer
Joined
·
34 Posts
Discussion Starter · #14 ·
looking to buy PUMP

anyone have any good advice for a replacement pump? Its for my 99 Ram 2500 quad,short bed, 24 valve CTD with EDGE and monitor, new lift pump,filters and 4 inch stainless exhaust. Ram used to tow 30ft fth wheel RV on weekends. Looking for advice from experience!!!A good price helps!:CRY:
 

· Registered
Joined
·
1,816 Posts
You should try starting a new thread under wanted to buy, or something accordinly, that will get you more attention!!!:thumbsup
 

· Registered
Joined
·
7 Posts
2001 dodge 4x4 2500 ctd goes into limp mode engine light comes on codes po234 and po237 come up dead power then it comes out of it for a while checked the volts to a new map senser checked the grounds seem to be good whould this cause the overboost condition when it acts up i have no boost no pedel then it seems to come back if you put it to the floor the boost will slowly kick in would my tps cause any of these problems any one have any answers
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top