Dodge Cummins Diesel Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
7,018 Posts
Discussion Starter #1
It started last week, when I started leaking fuel out my injection pump. I tfound and fixed my leak, it was the fuel inlet adapter leaking out the O-ring. Then I I drove all week and finally all ended thrusday. I drove it all day and started it about 30 times and when I got home I parked it and replaced the air filter and intake horn. started it and drove it 10feet to the curb to get another vehicle out and when I got back 2hours later I noticed the Lift pump would only come on a prime for a half a second and then while cranking it never came on; I also noticed that the injection pump was leaking once again at the case halves right under the computer. So I removed the stealth cover and put the original back on and solved the leak, but alot of fuel reached the circuitboard. I spent all day friday and this afternoon to find out why it wouldnt come on a stay running. so i gave up and ran the pump streight to the battery to move it into my garage and not it wount fire, I bled all the fuel injection lines and there is plenty of fuel coming out, but it dont pulse with pressure, it just comes out steadily.

I have come to the conclusion that I think its the ECM, since the lift pump and injection pump dont seem to be working, but could the fuel in the circuit bord affect the injection pump and ECM?

The pump is only about 1 year old and only has 15k miles on it. always had good fuel pressure.
 
1 - 1 of 1 Posts
Top