Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hello all! I have a 2003 dodge 3500 2wd automatic.

Went to get in the truck this morning and noticed that the batteries were dead(less than a year old). It's been sitting hooked to our cattle trailer for a week or so. I have a edge cts monitor on it and I've noticed sometimes that it would stay on after the ignition is off and I usually unplug it to keep the batteries from going dead but my dad didn't know. So after jumping the truck off and going to chapel hill and back now my gauges quit and chime comes on for 4 or 5 beeps and then everything is back to normal. It does it every 5 minutes 2 minutes sometimes every second lol I'm lost. I had the batteries checked and they appeared good and alternator tested out good. I have cleaned the cables ground straps on both fenders. Any help would be awesome and greatly appriciated!! I did have a code p2509 I think that's what it was. I have cleared it and now can't get it to pop back up
 

·
Registered
Joined
·
33 Posts
Try looking an making sure your cts is properly power with the correct fuse in the correct fuse outlet, and not one supplying constant 12v. You need key on 12v source and your battery won't drain.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Ok I'll check that. well the flickering gauges and the annoying door chime stopped after I unplugged the cts monitor and as soon as I plug it back in it starts all over again. Any thoughts?
 

·
Registered
Joined
·
33 Posts
Sounds like it may be the cats playing with the ecm maybe give edge a call?
 
1 - 4 of 4 Posts
Top