Dodge Cummins Diesel Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
so if I have a 1st gen 5.9 and when I purchased it the previous owner put a 2005 turbo on it what can I do to get more boost and have less lag... currently I have an after market fuel pin and have the fuel screws all the way up. It has a 4" exhaust. I have a boost gauge and the most boost I get is 36, but the turbo doesn't get more than 10 psi until I am at 2000rpm or more. On the freeway I run at around 4psi going 60. I was told that the turbo that is on it has a 9 housing.... doesn't that sound right? all I really know about the turbo currently on it is that it came from an 05 and it has a different housing...
 

·
Registered
Joined
·
1,846 Posts
Do you have a temp gauge? If not, I would not touch anything till you do get one.
 

·
Registered
Joined
·
1,057 Posts
umm why are you not satisfied with the boost. unless you have head studs and a thicker head gasket you dont want to run it more. the turbo you have is a he351 and i dont know why its laggy mine is great
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
can you tell me more about you boost... maybe I am just being picky.... whats the most boost you can get? Whats the most boost you can sustain? I can hit 36, but then it drops to 32. Really its the lower end that I have a problem with.... on the freeway what are you running boost presure at? From all my reading tonight I wonder if I need to get larger injectors and a different lift pump have you heard anything?
did you weld your blowoff closed?
 

·
Premium Member
Joined
·
11,978 Posts
it's not a blow off valve...it's a wastegate...and there is a hole where the solenoid goes on the CR's...and yes that has to be plugged off somehow
 

·
Registered
Joined
·
1,017 Posts
haha, complaining about lag with an HE351 turbo.
 

·
Registered
Joined
·
1,057 Posts
your turbo spools better than any other turbo of its size almost guarenteed i hit about 27 pounds and the drop to about 25 my cross over tube i think might have a boost leak inn it though and i run about 5 psi going 60mph and thats all the speeed i do i dont have an over drive tranny
 

·
Registered
Joined
·
1,131 Posts
Thats not to shabby i dont think you can get much better low end than with a 9cm housing lol
 

·
Registered
Joined
·
7,016 Posts
Ats sells your plug for the solenoid. check them out I think they use them for the coumpound setup they add to factory turbo
 

·
Registered
Joined
·
486 Posts
My W350 will hit 42 and fall to 39-40 with the wastegate hooked up, but with it adjusted not stock. Cruising down the road at 65 mph it says around 5 ish psi on flat land. Don't really understand the lag question though, mine will hit 40 almost insant once its hit at 5psi.
 
1 - 11 of 11 Posts
Top