Dodge Cummins Diesel Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
497 Posts
Discussion Starter #1
got my new quad BF yesterday and did my instal not very impressed with it. might of got 1-2psi more if that??????:confused013::confused013:
 

·
US Army June 78-June 06
Joined
·
1,013 Posts
got my new quad BF yesterday and did my instal not very impressed with it. might of got 1-2psi more if that??????:confused013::confused013:


If you are useing the Edge to read your boost it is not going to give you a true reading. Your Edge reads from the OBD II or from the map sensor. Well then it is fooling your readings. The only acurate way to get a true reading is to have a mechanical boost gauge. Now there was some debate on here about hooking the Edge up differently and it would read right but I am not sure anyone ever got this working.
 

·
Registered
Joined
·
1,591 Posts
idk what mine is because i dont have a mech boost guage yet but turbo is def louder than it was
 

·
World Champs!!!
Joined
·
24,829 Posts
Really, the place your really going to use the boost fooler and see much gain from it is using an aftermarket turbo. On a stock turbo, yea your only going to get a little bit more pressure out of it, but your already likely out of its efficiency range so your almost negating it. Now, step up to a different turbo, and youll definately need one, otherwise your going to be throwing overboost codes, which I believe defuels the engine. Not sure on the defuel though...
 

·
Registered
Joined
·
83 Posts
got my new quad BF yesterday and did my instal not very impressed with it. might of got 1-2psi more if that??????:confused013::confused013:
i also got mine yesterday thanks to James at RSD, I installed it and there is alot more turbo noise. At a steady pace you can hear the turbo the whole time now. It also feels good but i havent had alot of time to drive it yet. No gauges yet so i dont know about the psi deference, sounds like more. Hope it works out for U:thumbsup:
 

·
Registered
Joined
·
849 Posts
If you are useing the Edge to read your boost it is not going to give you a true reading. Your Edge reads from the OBD II or from the map sensor. Well then it is fooling your readings. The only acurate way to get a true reading is to have a mechanical boost gauge. Now there was some debate on here about hooking the Edge up differently and it would read right but I am not sure anyone ever got this working.
The statement about the Edge not reading accurate is untrue. My Edge reads the same as my boost gauge plumbed into the intake horn. As far as how to hook it up... http://www.cumminsforum.com/forum/6-7l-performance-parts-discussion/139586-zilla-boost-foller-edge-j-hook-up-advice.html
 

·
CF Administration
Joined
·
8,844 Posts
The statement about the Edge not reading accurate is untrue. My Edge reads the same as my boost gauge plumbed into the intake horn. As far as how to hook it up... http://www.cumminsforum.com/forum/6-7l-performance-parts-discussion/139586-zilla-boost-foller-edge-j-hook-up-advice.html
the reason people say that is because if a boost fooler is working the way it is suppose to it will send the ecm a different boost signal then it is actually getting. The edge might read the boost of the map sensor instead of the obd2 port thats probably why the edge reads correct it gets the true reading before the ecm sees it, the pmt, or insight on the other hand will more then likely read it wrong because they are hooked up from the obd2 not map sensor I hope I just made sense to you guys and cleared up a little confusion.
 

·
CF Administration
Joined
·
8,844 Posts
also its edge reading from the map sensor and boost fooler plugged in to read right would be the same as haveing a pressure box on and a rail pressure guage, it fools the computer but you can see the true readings if hooked up right, thats a much better example to help out explaining it.
 

·
Registered
Joined
·
497 Posts
Discussion Starter #9
i am using my auto meter gauge ....
 

·
Premium Member
Joined
·
258 Posts
the reason people say that is because if a boost fooler is working the way it is suppose to it will send the ecm a different boost signal then it is actually getting. The edge might read the boost of the map sensor instead of the obd2 port thats probably why the edge reads correct it gets the true reading before the ecm sees it, the pmt, or insight on the other hand will more then likely read it wrong because they are hooked up from the obd2 not map sensor I hope I just made sense to you guys and cleared up a little confusion.
I tend to agree with this. If the edge is plugged in to the map snesor first the attitude gauge could be taking its own reading without running through the ECM. I will unplug my OBII port and run around and see if I still get boost readings. That would definately confirm this theory.
 

·
CF Administration
Joined
·
8,844 Posts
I tend to agree with this. If the edge is plugged in to the map snesor first the attitude gauge could be taking its own reading without running through the ECM. I will unplug my OBII port and run around and see if I still get boost readings. That would definately confirm this theory.
not sure if it would confirm it or not, if egts will show with it unplugged then the boost should you would think, but might have to call edge and ask them about it.
 

·
World Champs!!!
Joined
·
24,829 Posts
But doesnt the monitor get power from the OBDII port? No pluggy-in, no gauges, correct?
 

·
Premium Member
Joined
·
258 Posts
That is not correct. The Attitude gauge stays on when unplugged from the port. I have to do this often with my DPF-R and I know I still have EGT with it unplugged. I will see if it reads boost with it unplugged in the morning.
 

·
World Champs!!!
Joined
·
24,829 Posts
That is not correct. The Attitude gauge stays on when unplugged from the port. I have to do this often with my DPF-R and I know I still have EGT with it unplugged. I will see if it reads boost with it unplugged in the morning.
Ah ok. I didnt know if they got power from there or not...I do now though
 

·
CF Administration
Joined
·
8,844 Posts
they have a power wire going to the fuse box
 

·
Registered
Joined
·
261 Posts
got my new quad BF yesterday and did my instal not very impressed with it. might of got 1-2psi more if that??????:confused013::confused013:
Has your egt's gone down any?
 

·
Registered
Joined
·
262 Posts
think you could stack the boost foolers? and get really ignorant on the stock turbo?
 

·
Registered
Joined
·
581 Posts
mine gets a boost reading but it is way off and the boost will go up and down with the throttle, but at idle im geting like 13lbs of boost.
 

·
Registered
Joined
·
262 Posts
mine gets a boost reading but it is way off and the boost will go up and down with the throttle, but at idle im geting like 13lbs of boost.
13! wow! spooled and ready full time huh! invest in a manual guage?
 

·
Registered
Joined
·
581 Posts
no thats with the edge unpluged for the obd II port.
 
1 - 20 of 39 Posts
Top