Dodge Cummins Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
Today when I left work my MM3 display did not come on and it had a light flashing red,red,green,red,red any ideas? It is on my 05
 

·
Registered
Joined
·
579 Posts
I'm not sure but I'm curious as to what the light flash sequence would mean also. Did you try unplugging the MM3 and plugging it back in again?
 

·
Registered
Joined
·
285 Posts
Discussion Starter #3
I'm not sure but I'm curious as to what the light flash sequence would mean also. Did you try unplugging the MM3 and plugging it back in again?
Yep just got home from work and this morning before I left I did just that.Unplugged it from the OBD then plugged it back in and it worked!
 
  • Like
Reactions: CTD NUT

·
3 footin' through life
Joined
·
12,341 Posts
I've had some weird stuff happen a handful of times. Always corrected with an unplugging.
 

·
Clayton @ Dude's Diesel Performance
Joined
·
3,619 Posts
Today when I left work my MM3 display did not come on and it had a light flashing red,red,green,red,red any ideas? It is on my 05
Low voltage can cause this issue, how are your batteries? The micro usb cable is super fragile and can cause these issues as well if damaged.

Like stated if your connection is good, and micro usb is not damaged then normally a simple unplugging and plugging back in the obd2 port will reset it and it normally starts working again.
 

·
Registered
Joined
·
1,381 Posts
Subscribing. I'm looking at the MM3 for my 05. Currently running a Smarty JR. Like the additional power and torque, better mileage and lower EGT's, but don't like the smoke. Are you running Smarty tuning or custom tuning?
 

·
Registered
Joined
·
1,381 Posts
Subscribing. Glad you got it fixed. I'm looking at the MM3 for my 05. Currently running a Smarty JR. Like the additional power and torque, better mileage and lower EGT's, but don't like the smoke. Are you running Smarty tuning or custom tuning?
 

·
Registered
Joined
·
579 Posts
Subscribing. Glad you got it fixed. I'm looking at the MM3 for my 05. Currently running a Smarty JR. Like the additional power and torque, better mileage and lower EGT's, but don't like the smoke. Are you running Smarty tuning or custom tuning?
The MM3 is only for custom tuning with UDC Pro and is not offered with any canned Smarty tunes. The level of control is amazing and in the hands of the right tuner, it's a powerful tool to get your truck set up exactly they way you want it.
 
  • Like
Reactions: MDSWA

·
Registered
Joined
·
579 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #10
Subscribing. I'm looking at the MM3 for my 05. Currently running a Smarty JR. Like the additional power and torque, better mileage and lower EGT's, but don't like the smoke. Are you running Smarty tuning or custom tuning?

Sorry I haven't been back been super busy,I have custom tunes by Gordon,on here he is dodge74 I think.
 

·
Premium Member
Joined
·
126 Posts
I posted this on another forum on my 16...

“5 months later and finally figured it out. So I finally had a chance to diagnose the problem. The usb cord that plugs in back of the mm3 had become larger in diameter than the connection itself(if that makes since lol). We called mm3 and asked them about it and he said to take pliers and gently squeeze on the metal conector. Well I did it and now the connection is perfect. Hadn’t gone off yet.”

Hopefully this helps.
 

·
Registered
Joined
·
579 Posts
Interesting...a growing connector. Thanks for the tip.
 

·
Registered
Joined
·
55 Posts
I posted this on another forum on my 16...

“5 months later and finally figured it out. So I finally had a chance to diagnose the problem. The usb cord that plugs in back of the mm3 had become larger in diameter than the connection itself(if that makes since lol). We called mm3 and asked them about it and he said to take pliers and gently squeeze on the metal conector. Well I did it and now the connection is perfect. Hadn’t gone off yet.”

Hopefully this helps.
Interested. Had same problem today on my 14, with mm3. Tried unplugging and plugging back in and even took out the sd card and blew in it like an old Nintendo game to no avail. Gonna check out the USB cord tomorrow. Thanks for the advice!
 

·
Registered
Joined
·
285 Posts
Discussion Starter #14
Mine still does this on occasion I will have to check out that cable!
 
  • Like
Reactions: Mechanick858

·
Registered
Joined
·
55 Posts
Yup it was the cable. Here is a pic of the vin and license in the calibration signature. I called DRD and gave em the vin, they said it wasn"t their calibration. I wonder if its Anarchys? Since it ends in AD?
 

Attachments

·
Registered
Joined
·
12 Posts
I just got the MM3 tuner on my 05... And I have no change in Egt's and fuel mileage!! When you guys change levels do you see rail pressure go up or anything? Cause thinking mins not changing!!! Any way to tell??
 
1 - 16 of 16 Posts
Top