Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Yesterday, went to start my '01 and it started getting lots of white/blue smoke (note - hot day ... temperature about 100 deg). Idles OK, but started missing as soon as step on accelerator. First time it does this. Checked oil and cooling system - does not look like a blown head gasket. Fuel filter fairly new. Had to change out stock LP about a year ago due to intermittent power loss. Has been OK since except I started getting very short/infrequent power loss episodes about a month ago. Would run a week without any problem and then get the power loss - usually at slow cruising speed with no load on engine. Just Tap the accelerator and it would come right out of it and be good for another week or so. Does this problem sound like another LP problem or am I looking at a failed VP44?
 

·
Registered
Joined
·
264 Posts
sounds to me your VP went south, if i were to guess i would get a new VP and an airdog, or fass something you know will keep the VP alive and always a set of gauges Boost,pyro,Fuel pressure than you can keep an eye on it.
 

·
Registered
Joined
·
1,821 Posts
Check for a P0216 code. Turn the key off and on 3 times real fast. If you miss it, head to an auto parts store that can hook up a scanner to check them for you.
 

·
Premium Member
Joined
·
25,253 Posts
Moved to the 98.5-02 powertrain forum for better exposure.



Dodge | Commins | Forum
 

·
Tech Specialist
Joined
·
1,493 Posts
Bet the VP is dead and I'll bet that year old LP is dead as well. Get a fuel pressure gauge and check it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Need Price on a replacement VP44

OK - after reading the responses and having researched other similar threads, I am convinced that the VP is dead or dying. What are my options for buying a replacement?
 

·
Tech Specialist
Joined
·
1,493 Posts
There are several companies that sell them. I recommend going with an SO pump. They are cheaper than a HRVP, they dyno the same as a HRVP with a wire tap box, and you don't have to deal with that goofy idle that they get sometimes.
 

·
Registered
Joined
·
101 Posts
I have a 2000 with the edge comp and I am having the same issues. Is there a way I can test the injection pump and the lift pump before I spend the money on them and it not fix the problem? Thanks
 
1 - 8 of 8 Posts
Top