Dodge Cummins Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
When you leave your truck idle in neutral and have the emergency brake on, how strong is it?
Do you trust it just on the level or on a grade too?
How about with a trailer on?
 

·
Registered
Joined
·
10,348 Posts
My 05 works great and I haven't had to readjust it yet. I will generally put the motor in gear, but that's just a precaution. My ebrake has never slipped on me, even hooked up to the TT.
 

·
Premium Member
Joined
·
1,930 Posts
mine has held on grades with a trailer, only about 3k lbs but it still held great and i always leave it in neutral.
 

·
Registered
Joined
·
346 Posts
I trust it enough to always leave my truck in gear.
 

·
Tech support junkie
Joined
·
4,986 Posts
Yes it works very good but if i shut the truck off it alwaysgoes in gear no matter what
 

·
Registered
Joined
·
901 Posts
I don't like leaving it set with hot brakes.... Guess it carries over from airplanes. But other than that the brake itself if awesome. It with lock up the wheels with less than half travel.
 

·
Registered
Joined
·
13,900 Posts
I don't like leaving it set with hot brakes.... Guess it carries over from airplanes. But other than that the brake itself if awesome. It with lock up the wheels with less than half travel.
you realize that the parking brake does not utilize the service brake pads, right? :eek:
 

·
Registered
Joined
·
28 Posts
My brakes work great, I use the parking brakes all the time. Heck, I have put it in gear before and not release the brake (my memory is going) and the truck won't budge.
 

·
Registered
Joined
·
760 Posts
i know this is in the 2010+ general discussion but every one seems to be puttin in there input so i'll add mine. my park brake failed once on my '01 6 speed. i use it all the time when i park the truck why its runnin but always put it in gear when shut off. one time i had the truck runnin and a 16ft trailer hooked up and i was loading my jeep on it and the park brake let go! :shock: it was on flat ground but with the jeep pushing on it, it started rollin away! had to jump out and chase it. not far it really only rolled 15 - 20 feet when i stoped it. what had happened was the cable broke right where it goes in to the brake on the pass side. when it let loose it lost tension on both brake cables. it was pretty rusted were the cable broke. so i replaced both cables, the one on the driver side was a little rusted also just on that short section, maybe 1" long, where the cable is exposed right before it goes in to the park brake. i still trust my park brake to park my truck why its running or even loading a trailer. :thumbsup: just my story.
 

·
Registered
Joined
·
860 Posts
ahh for loading heavy loads they suck, hauling forklifts on gooseneck or like a bigger tractor my truck likes to roll around haha, only started heading towards a house once tho! ohh and it really dont work when the gooseneck picks the entire back end of your truck off the ground!
 

·
Registered
Joined
·
901 Posts
you realize that the parking brake does not utilize the service brake pads, right? :eek:
Yea, but it still uses the rotor right? Or does it have a drum inside it like the gm's do? I never look in this one since I haven't done any maintenance on it myself yet.
 
1 - 14 of 14 Posts
Top