Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
831 Posts
Discussion Starter #1
Here is my situation, was hauling hourse trailer from missouri to kentuckey i was making about 45 psi on boost and pulling hard on the hills it was running really good. then it just would not pull as hard it would not even light the bottom turbo just sit there at about 25 psi on boost no smoke. it was almost like it was not fueling hard anymore. we stayed the night in kentuckey and then in the morning it was all good for about 40 min then it started not fueling hard again it will only do it when it is really hot after u have run it for a while. if you let it idel why u eat lunch and then come back to it after it has cooled a little it will be ok for about 5-10 min could the relief valve be giving it up when it gets hot under the hood?
 

·
......................... .....
Joined
·
2,798 Posts
is it defueling to the point of less than stock? id let it cool down, unplug the edge and drive it, see what it does cold, and hot, if you dont loose power with the edge unplugged, maybe its having issues, or pulling fuel for another reason. any of the gauges acting different when its happening?
 

·
Registered
Joined
·
831 Posts
Discussion Starter #3
already have the edge unpluged and it mad no diff i dont have a rail press gauge but i can check it at work. could the relief get weaker when it gets hot
 
1 - 3 of 3 Posts
Top