Dodge Cummins Diesel Forum banner

Loud POP with exhaust brake on???

1136 Views 5 Replies 3 Participants Last post by  john_ak
Hey guys my truck has only 1600 miles on it and within the last 300-400 miles with the exhaust brake on it makes very loud pop almost as if a backfire only when i press the accel a little after slowing down with the exhaust brake and it does it every time at around 40-50 mph. So for instance im slowing down from 50-45 my foot off of the accel and brake pedal letting the exhaust brake do its thing and make the cool whistle then i go to accelerate a little and it pops almost like a valve is closing hard or even a exhaust backfire??any ideas or is this normal?? Thanks
1 - 6 of 6 Posts

· Registered
Joined
·
98 Posts
I used to get that too, I took it in the dealer they check reflashed with what I think is BA flash and never heard it since. The tech said it was a timing thing? That's all I can tell you about it.
 

· Registered
2012 RAM 2500 SLT Regular Cab
Joined
·
468 Posts
Discussion Starter · #3 ·
thanks ramdog that actually makes sense! If its timing related im not burning all the fuel and when i get back into the accelerator it ignites the unburnt fuel. Cool im heading to the dealer tomorrow.
 

· Registered
Joined
·
300 Posts
I don't remember for sure but it was under 5K, they reflashed my ECM and it went away for a day or two. Then they cleaned the turbo, that was good for one day. Then finally put the "new" turbo on, no problems since.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top