Dodge Cummins Diesel Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
OK, I have trouble. Sorry for the long post but I would appreciate any input. I have a 2014 Ram 6.7 diesel and an Edge JWA. I haven't had any trouble until last week when the temperature dropped below -10. The truck started stuttering and it threw the P0087 code. I parked it inside overnight and it was fine the next day. The check engine light was still on and the CTS would not clear the code. I took it to my nearest "aftermarket friendly" Ram dealer to fix the fuel heater (my opinion) and clear the code. They unplugged the CTS at the data port and gave me the following updates 18P26182 (ABS P-26 update), 181904BD (Powertrain control module update), and 18191892 (DEF module update), then plugged the CTS back in. Truck ran fine, no codes, BUT - the fuel economy gauges on the CTS were not reading correctly (instant and average). It also seemed like the boost gauge (on CTS) wasn't reading right. Last night the temp dropped to -9 and the truck started running rough again. Threw the P0087 code plus every injector threw a code for circuit open. I decided I was going to give my dealer hell for failing to fix the original problem. To that end, I figured I better take my JWA off so they couldn't blame it. I removed the entire JWA/CTS from the truck. Now when I start it, the check engine light is on, ABS light is on, and the speedometer doesn't work (both the needle gauge and digital EVIC gauge). Runs fine, but obviously something is very wrong. I have an appointment at the dealer Monday, I hope they can straighten everything out, but I am very nervous. I plugged my CTS into Fusion and it was updated, IDK what that will do. I liked my JWA until now, if the Dealer gets everything running right, I'm afraid to reinstall it.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top