Dodge Cummins Diesel Forum banner

loss of acceleration??

863 4
so lately i been having a lot of problems and one of my problems is when accelerating (pressed down a good bit but not floored) i get a sudden power loss tht maybe last 1 sec like its gone into limp mode but then picks up power right bck. im running the superchips cortex economy tune. my truck has 167,000 miles thanks
1 - 5 of 5 Posts

· Registered
Joined
·
70 Posts
well it could be a number of things, but no codes would lead me to believe its the lift pump. does it do it in any gear at the same RPM? or just in a specific gear. lets get a little more info.
 

· Registered
Joined
·
453 Posts
Discussion Starter · #3 ·
the lift pump comes on when ever i turn the ignition on so idk?..and i havent even checked the RPMs to see if they die down or not. it will do it from a dead stop when ever u take off fast or rolling. only seems to do it whenever the turbo spools up and really starts pulling. i uninstalled my superchip programmer back to stock and so far hasnt done it, so maybe it was a de-fuel caution the programmer had??
 

· GA CUMMINS CREW PREZ & Captain of the USS FAILBOAT
Joined
·
5,525 Posts
are you getting a cel with it? and could possibly be the lift pump, but if it was then you would have a fuel delivery code stored, anytime the 3rd gen trucks loose fuel or sustained pressure there will be a hard code stored.... doubt it was a defuel from the programmer....
 

· Registered
Joined
·
453 Posts
Discussion Starter · #5 ·
yeah ur right still does it with the programmer off. and i watched the RPMS today and they seem to move down a hair bit then climb on up when it happens. i get no codes, it starts right up with no problem, and i dont get any rough idle or excessive smoke, it does puff a small grayish cloud when it sits over night and i start it in the morning. whts a cel??
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top