Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 3 of 3 Posts

·
Cummins CrAzY
Joined
·
1,366 Posts
Discussion Starter · #1 ·
Last weekends I changed the oil, oil filter fuel filter and inline fuel filter for my FASS pump also over sized banjo fittings. I even made sure and contacted FASS to make sure I had the right pump. I primed the system and she fired right up. She sat all week and I went to start her up and she just cranked prob 12 times before she would even sputter. Tried again and she started. Let it sit for more then 30 to 45 min and it does it again. I know if you use the inline filter with the paper filter you will lose prime, but they said it was thr right one. I did open some valve on the side of the fuel filter, I think it is a water seperator. Would that have anything to do with anything? Could it be the vp getting weak?
 

·
Cummins CrAzY
Joined
·
1,366 Posts
Discussion Starter · #2 ·
Last weekends I changed the oil, oil filter fuel filter and inline fuel filter for my FASS pump also over sized banjo fittings. I even made sure and contacted FASS to make sure I had the right filter. I primed the system and she fired right up. She sat all week and I went to start her up and she just cranked prob 12 times before she would even sputter. Tried again and she started. Let it sit for more then 30 to 45 min and it does it again. I know if you use the inline filter with the paper filter you will lose prime, but they said it was thr right one. I did open some valve on the side of the fuel filter, I think it is a water seperator. Would that have anything to do with anything? Could it be the vp getting weak?
 

·
Cummins CrAzY
Joined
·
1,366 Posts
Discussion Starter · #3 ·
Ok so its not my prime. I primed my system and it still took 20 revolutions to fire up. I did reposition my guages. is there asny way it could have some thing to do with the tube that goes to my boost guage? I know there arnt any leaks @ the engine. Once it fires up it is good, no loss of power and 40 psi of boost. What will make it not fire right up?
 
1 - 3 of 3 Posts
Top